Making a focused element un-focusable does not always un-focus it

RESOLVED DUPLICATE of bug 570835

Status

()

Core
General
RESOLVED DUPLICATE of bug 570835
a year ago
a year ago

People

(Reporter: Domenic Denicola, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

(Reporter)

Description

a year ago
Firefox fails the web platform tests at https://github.com/w3c/web-platform-tests/pull/4160 for all ways of making an element un-focusable, except removing it from the DOM.

The spec mandates all such ways of making something un-focusable be treated equally: https://html.spec.whatwg.org/multipage/interaction.html#focus-fixup-rule-one

Browsers are generally fairly inconsistent, as discussed in the web platform tests PR. But the most sensible behavior to converge on is the spec's behavior, which is uniform across all the different ways of making something not-focusable.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570835
You need to log in before you can comment on or make changes to this bug.