If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when venkman is used

RESOLVED INVALID

Status

Other Applications
Venkman JS Debugger
--
major
RESOLVED INVALID
16 years ago
13 years ago

People

(Reporter: Håkan Waara, Assigned: Robert Ginda)

Tracking

Trunk
mozilla1.0
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have a tiny XUL application. This is what I do to reproduce this crash:

1. mozilla -venkman
2. (In venkman:) open-dialog chrome://myXulApp/content
3. Set a breakpoint in some code
4. Make the breakpoint hit
5. Click "Next" in the debugger until a XPCOM object has been createInstance'd

Now, if I try to expand the "Scope" twisty, in that function, I get this crash.

If you want the code too, let me know.

nsMsgAccountManager::GetIncomingServer
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccountManager.cpp, line
464]
nsMsgAccount::createIncomingServer
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccount.cpp, line 166]
nsMsgAccount::GetIncomingServer
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccount.cpp, line 114]
nsMsgAccountManager::LoadAccounts
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccountManager.cpp, line
1339]
nsMsgAccountManager::GetAccounts
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccountManager.cpp, line
1113]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.c
pp, line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line
2027]
XPC_WN_GetterSetter
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1299]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 790]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2502]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2578]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3390]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp,
line 1218]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp,
line 2210]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line
3457]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
6104]
nsButtonBoxFrame::MouseClicked
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line
195]
nsButtonBoxFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsButtonBoxFrame.cpp, line
142]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
6073]
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
6024]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp,
line 2603]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp,
line 1686]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
6077]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
5979]
nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2043]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line
306]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1863]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 869]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 886]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4713]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4963]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3630]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1131]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00648c16
(Assignee)

Comment 1

16 years ago
http://lxr.mozilla.org/mozilla/source/mailnews/base/src/nsMsgAccountManager.cpp#463

Looks like a missing null check against m_prefs, possbily in other functions in
that file too.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

16 years ago
hwaara says it was his fault for creating a service as a component.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.