Closed Bug 13149 Opened 21 years ago Closed 21 years ago

Appruner crash on startup. Some Viewer crashes.

Categories

(SeaMonkey :: General, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: kberk.spamaway, Assigned: don)

Details

Overview Description: Apprunner crashes on startup.  Viewer crashes on tests 14
and 15 and does nothing on test 17.

Steps to Reproduce:
1) Launch Aprunner.
2) To reproduce some of the console errors you must (F5) in VC to continue past
the breakpoint.
3) In Viewer, just run the failed tests.
4) In viewer or apprunner trying to browse the web crashes with the same
errors.  I have not tried many sites though.

Actual Results:
Starting Apprunner, the console gives me this:

nsNativeComponentLoader: autoregistering E:\mozilla\dist\WIN32_D.OBJ\bin\compone
nts
nsNativeComponentLoader: autoregistering succeeded
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Profile Wizard and Manager activites : End
ProfileName : mozProfile
ProfileDir  : E:\mozilla\dist\Users50\mozProfile
XPInstall Component created
Initialized app shell component {18c2f989-b09f-11d2-bcde-00805f0e1353}, rv=0x000
00000
Initialized app shell component {4a85a5d0-cddd-11d2-b7f6-00805f05ffa5}, rv=0x000
00000
plugins at: E:\mozilla\dist\WIN32_D.OBJ\bin\plugins
Note: frameverifytree is disabled
Note: verifyreflow is disabled
failed to get sidebar_pref
Doing navigator.js Startup...
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/


Then I receive this error:

The exception Breakpoint
A breakpoint has been reached.
(0x80000003) occured in the application at location 0x77f76274.


If I use VC6 to continue, I get this error from the Apprunner console:

JavaScript error: uncaught exception: [Exception... "Component returned failure
code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIBrowserInstance.loadInitialPage]"  ns
result: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///E|/mo
zilla/dist/WIN32_D.OBJ/bin/chrome/navigator/content/default/navigator.js :: tryT
oSetContentWindow :: line 316"  data: no]


If I load Viewer instead of apprunner, I get no crashes on startup.

However if I run viewer through the sample tests, the first 13 tests work fine.
Test 14 and 15 crash with the same breakpoint code as apprunner was.  I don't
get anything
in the viewer console if I use VC6 to continue.  Test 17 does nothing, but does
not crash like
tests 14 and 15 were.  Test 16 works fine.

Expected Results:

Build Date & Platform Bug Found: Tree pulled the morning of September 4th.

Additional Builds and Platforms Tested On: Pull the tree several times this
week with the same problem.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Today's build seems to work (more or less) on all platforms without crashing.
Status: RESOLVED → VERIFIED
Old bug...this is fixed.  Marking Verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.