"Forward/Back" arrows in Disco Pane menu

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: ValentinaP, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Steps to reproduce:
1. Open your Firefox browser
2. Access about:addons
3. Click to play the video
4. Make the video "full screen"
5. Navigate between tabs
6. Close "full screen"

Expected results:
Forward/back arrows are no longer displayed.

Actual results:
The arrows are still displayed.

Notes/Issues:
The arrows disappear after page refresh.
Reproducing on -prod using FF49.0.2(Win 7)
Screenshot for this issue:http://screencast.com/t/XK5OghWa
I've never seen those arrows. Is there something I have to do to get them? I'm not sure what they do.
I don't really understand the description and trying to look at the screen cast I just get "We're sorry! There was a problem with this page."
(Reporter)

Comment 3

a year ago
(In reply to Andy McKay [:andym] from comment #1)
> I've never seen those arrows. Is there something I have to do to get them?
> I'm not sure what they do.
They help you go back/forward through the add-ons manager menu.
Are displayed, as I mentioned in steps, in full screen, after navigating in the add-ons manager tabs, and still maintaining after ESC the full screen.

(In reply to Andrew Swan [:aswan] from comment #2)
> I don't really understand the description and trying to look at the screen
> cast I just get "We're sorry! There was a problem with this page."
Hope this works: http://screencast.com/t/blbmkg5vY1
Ah thanks for the video, that helped me understand how to get the arrows. It seems those arrows don't help navigation in the slightest and could be removed unless there is a specific accessibility reason for them.
Thanks the new screencast did work.
Those buttons are meant to be shown when the add-ons manager is in its own top-level window without the browser chrome since in that case the browser back/forward buttons are obviously not available.
The code that decides whether to show them is here: 
http://searchfox.org/mozilla-central/rev/f5c9e9a249637c9abd88754c8963ecb3838475cb/toolkit/mozapps/extensions/content/extensions.js#2074-2103
I suspect that that logic just never accounted for the possibility of an embedded video going into full screen mode.
I can think lots of hacks we could do, but given the obscurity and low impact, I'm inclined to just let it slide.
We don't think this is important enough to worry about.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.