Update to Firefox 50.0b10 fails to install

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
11 months ago

People

(Reporter: bnk47, Unassigned)

Tracking

50 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8807171 [details]
FIrefox update failure-50b10.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161024172922

Steps to reproduce:

Attempting to update Firefox 50.0b10. First, the browser tries to download a 12.3MB file, then switches to the 54.2MB update file. 


Actual results:

After the download, the automatic attempt to install the update failed with the message: "Update failed"


Expected results:

As all previous instances, the update should have installed successfully.
(Reporter)

Updated

2 years ago
Component: Untriaged → Installer
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Installer → Application Update
Product: Firefox → Toolkit
Thanks for the report. I'd like to get a few log files from you so we can see why the updates are failing to apply. There are multiple kinds of logs to check because I'm not sure from the message you're seeing whether the problem is that updates are failing to download or downloading correctly but failing to apply.

1) Follow the instructions at [https://support.mozilla.org/en-US/kb/about-config-editor-firefox] to open the configuration editor, search for the preference called app.update.log and toggle it to true. Then, open the Browser Console either by selecting it from the Developer menu (wrench icon) or pressing Ctrl+Shift+J. Then open the About window. You should see some lines that start with "AUS:SVC" appear in the browser console; copy those lines and paste them here.

2) In the Windows File Explorer path box enter %LOCALAPPDATA% and press return, then navigate to the Mozilla\updates\ directory. There might be multiple subdirectories here; if so, open the one with the newest modified time. Now use the "Add an attachment" button above on this page to attach any of the following files that exist in that directory (don't worry about any that aren't there):
* active-update.xml
* updates.xml
* updates\last-update.log
* updates\backup-update.log
* 0\update.log
* 1\update.log

Thanks again.
Flags: needinfo?(bnk47)
Over a year with no reply from the reporter, so I'm closing this bug. Feel free to reopen if the problem is still happening and you can provide the requested information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(bnk47)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.