Closed Bug 1315215 Opened 5 years ago Closed 5 years ago

Window for Character inserting is not displayed properly

Categories

(Thunderbird :: Message Compose Window, defect)

50 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 52.0

People

(Reporter: alexis, Assigned: Paenglab)

Details

Attachments

(2 files)

Attached image screen capture
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36

Steps to reproduce:

In thunderbird with *French* localization :
I compose a new mail (or reply to one), and I try to insert a special character, like "À", "È", etc.


Actual results:

The window for character inserting is displayed, but "OK" and "Cancel" button are hidden.


Expected results:

The window should have been resized to the proper size, the 2 first categories "Accent sur les majuscules" and "Accent sur les minuscules" take 2 lines (in French thunderbird localization).
How weird, the menu looks fine to me in the en-US version on Windows 7. Richard, can you please take a look.
Attached patch bug1315215.patchSplinter Review
The cut off is because of the too long labels in French. With my normal desktop settings they fitted into the dialog without wrap. After setting the font to 12px I saw the issue with the French text. Interestingly with longer text like "Accent Uppercase Accent Uppercase" the dialog adjusted to the width of the text and needed not to wrap.

I've set the width to 20em, so no text should be needed to wrap and also the dialog looks a bitter, not so narrow and high.

Also with setting a width to the dialog the text wraps when longer and the dialog's height is calculated correctly.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8807901 - Flags: review?(jorgk)
Comment on attachment 8807901 [details] [diff] [review]
bug1315215.patch

Review of attachment 8807901 [details] [diff] [review]:
-----------------------------------------------------------------

> ... and also the dialog looks a bitter, ...
What? A bitter and grim looking dialogue, no, we don't want that ;-)

r=jorgk.

Please don't land this separately. I can land it with my data URI bug later.
Attachment #8807901 - Flags: review?(jorgk) → review+
https://hg.mozilla.org/comm-central/rev/c140c92d693ecf0231baf10331afabedca07fbbf
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
You need to log in before you can comment on or make changes to this bug.