loose handling of flash animations on css sheets

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: niconx, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

775 bytes, application/x-shockwave-flash
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1
BuildID:    20020311

Im not totally sure if this is a bug, but it is an instance of very loose css
coding and embedding being allowed by Mozilla, and could I see it causing
serious problems theoretically:

Mozilla requires either the flash tags <embed> or <object> (or both tags) to
have an id="css_stylename" property for the flash to show on the css sheet.  IE6
requires <object> to have the id="css_stylename" property set, and will not
render the page properly with just <embed> having the id="css_stylename" property.  

For reference here is some code that places a flash animation properly in an IE6
and Mozilla css sheet.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<head>
<style type="text/css">
#toplefttop
{
position:absolute;
left:0;
top:0;
z-index:1
}
</style>
</head>
<OBJECT 
id="toplefttop" 
classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
 WIDTH=18 HEIGHT=147>
<PARAM NAME=movie VALUE="toplefttop.swf"> 
<PARAM NAME=quality VALUE=high> 
<PARAM NAME=bgcolor VALUE=#FFFFFF> 

<EMBED 
id="toplefttop" src="toplefttop.swf" quality=high gcolor=#FFFFFF  WIDTH=18
HEIGHT=147 TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash">
</EMBED>
</OBJECT>
<html></html>

Above I explicitly set id="toplefttop" in the <object> and <embed> tags.  This
"either tag" behavior applies to Netscape 4.78, 6.2.1, and Mozilla 0.9.9.

Mozilla is assuming that <object> has the same id="css_stylename" property as
<embed>??!!  And <embed> is a child of the <object> tag, not a parent!!  I can
see how <object> would only need the id="css_stylename" property but now how
only <embed> would.

Reproducible: Always
Steps to Reproduce:
1. Cut, paste, and save the code I give in the description
2. Download a flash animation and name it toplefttop.swf
3. Open the saved html page with the reference code
4. Try removing the id="toplefttop" property of <embed> and/or <object>
5. Try loading in Netscape and IE browser versions

Actual Results:  Everything works but it shouldnt!  Mozilla is being a slut!
(Its being easy,... too easy)

Expected Results:  Mozilla should have said "hey u need to be more specific
mister!" and ignored the id="css_stylename" property in <embed>, thereby not
showing the flash animation on the css sheet.  Only if Mozilla is 100% sure then
it should assume <object> and <embed> have the same id="css_stylename"
property,... but only if its 100% sure.  Very few things are ever 100% sure ;c)

Am I right about this?  Should id="css_stylename" indeed be required to be
defined in both the <object> and <embed> tags, not just one of them, and
definitely not just <embed> which is a child of <object>?  Could this type of
thing cause some kinda memory leak?  Could this cause trouble when running
multiple versions/instances of flash in the same page?
(Assignee)

Comment 1

17 years ago
this is an invalid testcase I believe, the id values must be unique, try making 
each id attribute a unique value and see what hapens. Better yet, try using 
class instead.
(Reporter)

Comment 2

17 years ago
Created attachment 74827 [details]
a glowing flash animation
(Reporter)

Comment 3

17 years ago
This could be incorrect coding on my part, but that still does not negate the
fact that it lets me define the child tag <embed> and not define the parent tag
<object> with anything.
(Assignee)

Comment 4

17 years ago
the basic issue here is that currently we just pass through the object tag and
only process the embed tag, this will be changing in the next few weeks. We will
be supporting the object tag and de-emphasizing the embed tag. Once our support
is in place, this will not be the case.

Since we do not support the object element, I am marking this as wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 5

17 years ago
Try using unquie ID's on both the OBJECT and EMBED.

Comment 6

17 years ago
marking verif, pls reopen stating a reason, Thx!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.