Closed Bug 1315269 Opened 3 years ago Closed 3 years ago

The default action button in PopupNotification prompts should follow platform conventions

Categories

(Firefox :: Site Identity, defect, P2)

All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 53
Iteration:
53.1 - Nov 28
Tracking Status
firefox52 --- unaffected
firefox53 --- verified

People

(Reporter: past, Assigned: johannh)

References

Details

(Whiteboard: [fxprivacy])

Attachments

(1 file, 2 obsolete files)

The redesigned popup notifications always show the default action on the right, which matches platform convention on macOS & Linux. Windows always puts the default action on the left and UX (maritz, bwinton & shorlander) says we should respect that.
Attached patch button-order-fix.patch (obsolete) — Splinter Review
Here is how this could work, but I'm hoping there is a simpler solution that doesn't involve the preprocessor.
Whiteboard: [fxprivacy][triage] → [fxprivacy]
Maybe it will. Paolo suggested using flex order:

https://developer.mozilla.org/en-US/docs/Web/CSS/order

If anyone can give either of these a try that would be awesome, because I don't know when I'll be able to get back at this.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
This is an approach using flex-direction. Note that I haven't tested on actual Windows yet because my VM is still compiling. I'll also push a mozscreenshots build. Let's see what's faster.
Attachment #8811219 - Flags: review?(past)
Make sure you test the identity prompt that has the drop down arrow on the right of the secondary button.
Good point, this should work better!
Attachment #8811262 - Flags: review?(past)
Attachment #8811219 - Attachment is obsolete: true
Attachment #8811219 - Flags: review?(past)
Attachment #8807657 - Attachment is obsolete: true
Comment on attachment 8811262 [details] [diff] [review]
Reverse notification buttons on Windows to follow platform conventions

Review of attachment 8811262 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, assuming it works as expected in the password prompt as well.
Attachment #8811262 - Flags: review?(past) → review+
Iteration: --- → 53.1 - Nov 28
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
https://hg.mozilla.org/integration/mozilla-inbound/rev/248955c8a9cb68c2a97c103366af6d073e3bc2e0
Bug 1315269 - Reverse notification buttons on Windows to follow platform conventions. r=past
Duplicate of this bug: 1319471
https://hg.mozilla.org/mozilla-central/rev/248955c8a9cb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
I guess we want this to ride the train with 53
Yup, I don't think this was ever relevant for 52 :)
Confirmed the default action:
- on the right on Ubuntu 14.04, OS X 10.11.
- on the left on Win 7
Verified fixed Fx 53.0a2 (2017-02-03).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.