Allow Cookies window blocks surfing

VERIFIED DUPLICATE of bug 65521

Status

()

Core
Networking: Cookies
VERIFIED DUPLICATE of bug 65521
16 years ago
13 years ago

People

(Reporter: Georg Wild, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020313
BuildID:    2002031321

When you surf and a window opens whether to allow a bookmark or a alert window
to click OK it is not possible to do somethink other than click OK or yes or no!
This makes it also impossible to close one of such nasty pop-ups, even if you
ran to the X with the mouse!

Reproducible: Always
Steps to Reproduce:
1.open web page with no rule about bookmarks
2.let bookmark dialog open


Actual Results:  can't close other window until OK or yes or no clicked!

Comment 1

16 years ago
Georg, could you please give an example of a "web page with no rule about 
bookmarks"?
(Reporter)

Comment 2

16 years ago
Sorry, I mean "web page with no rule about cookies"!
This occurs when you turn on "Ask me before storing a cookie"
Summary: Allow Bookmark window blocks surfing → Allow Cookies window blocks surfing

Comment 3

16 years ago
"confirming" (although there might a more generic bug filed for this already ?)
using build 2002031608 on Win2k.
I sometimes get stuck with this kind of behaviour (I set 'ask for cookies'
pref), workaround is to use the Alt-Tab key on Windows to refocus on other
window. If I understood bug report well...
(Reporter)

Comment 4

16 years ago
I think you misunderstand my bug report!

When the mentioned happens I can't close any mozilla window and I can not open
any menu in any menu bar!

Comment 5

16 years ago
ok, I understand bug report now. If you want to get rid of popup windows, check
Edit -> Preferences -> Advanced > Scripts and Windows -> untick 'Open
unrequested windows'
But you're right though, the cookies window blocks any Mozilla user input. I'll
look for dupes (as it may have been reported before).

Comment 6

16 years ago
->cookies
Assignee: trudelle → morse
Component: XP Apps → Cookies
QA Contact: paw → tever
(Assignee)

Comment 7

16 years ago
This is not a bug -- the window is modal by design.  So at best this is a 
request for enhancement.

Furthermore, I believe that Robert Churchill has just checked in a patch that 
makes dialogs such as these no longer be modal.
This is a duplicate of the Linux-only "[linux] modal dialogs should only freeze
parent window (not all windows)"

*** This bug has been marked as a duplicate of 65521 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.