Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: valentin.gratz, Unassigned)

Tracking

({crash})

49 Branch
Unspecified
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

I left open Firefox with all tabs and when I came back on firefox, I clicked on a tab, and suddenly it closed and display a crash report.


Actual results:

So I send the report by requesting it starts and has given all tabs before the crash.


Expected results:

I don't know.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7

Comment 1

2 years ago
Please post the crash id from about:crashes
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Flags: needinfo?(valentin.gratz)
Keywords: crash
(Reporter)

Comment 2

2 years ago
I do not know if you can see it, or if I'm the only one to see: 
https://crash-stats.mozilla.com/report/index/aa1d0315-bfe5-420d-9a6d-6f8282161106

Comment 3

2 years ago
It is work, people can access it.
Flags: needinfo?(valentin.gratz)
(Reporter)

Comment 4

2 years ago
(In reply to YF (Yang) from comment #3)
> It is work, people can access it.

We must never give this page to give you all the details?

Comment 5

2 years ago
(In reply to valentin.gratz from comment #4)
> (In reply to YF (Yang) from comment #3)
> > It is work, people can access it.
> 
> We must never give this page to give you all the details?

I'm not sure what you mean. It provides some important information, but still lacks some clues.
(Reporter)

Comment 6

2 years ago
I'm sorry, but I followed the tutorial given above, and I have that information
The "OOM" in the crash signature stands for out-of-memory.  It means that Firefox
failed to allocate the memory it needed for the page and intentionally crashed.
The crash report also says "System Memory Use Percentage: 98" which confirms this.

We're aware of this problem in general and are working on improving it.
Primarily by running tabs as separate processes to avoid crashing all
of Firefox and instead just crash the process displaying that tab.
https://blog.mozilla.org/futurereleases/2016/08/02/whats-next-for-multi-process-firefox/
https://developer.mozilla.org/en-US/Firefox/Multiprocess_Firefox

Thanks for your report.  (I'm closing it because we already have bugs open
tracking the remaining work to fix this.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.