save complete web-pages with pictures sometimes is not possible

VERIFIED DUPLICATE of bug 158598

Status

--
major
VERIFIED DUPLICATE of bug 158598
17 years ago
13 years ago

People

(Reporter: sven_tewens, Assigned: bugs)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; de-AT; rv:0.9.8) Gecko/20020204
BuildID:    20020311

0.9.8 + 0.9.9:
sometimes web-pages - which are loaded completely - can't be safed (html +
pictures) - although all other pages off the same web-side can,  (they can e.g.
be safed with Opera 3.62 and i can't see any suspicious meta tag about this. It
even happens on www.mozilla.org !!)
One look in cache dir shows, that the mentioned page is not there either.
Sorry, but i can't find any systematics in this that could help you to locate
the bug.


Reproducible: Sometimes
Steps to Reproduce:
1. i can't find any regular behaviour
2.
3.

Comment 1

17 years ago
->ben
Assignee: trudelle → ben
What do you mean by "can't be saved"?  Is there an error message?  Or do things
look OK and nothing gets saved?

Comment 3

17 years ago
--> qa sairuh@netscape.com
QA Contact: paw → sairuh

Comment 4

17 years ago
I can verify this with build 2002041203 on Windows ME when I try to save a page
that's been generated by a bookmarklet. Like the linked images one from
http://www.squarefree.com/bookmarklets/pagelinks.html that creates a new page
where each thumbnail/link is followed by the image it links to.

When the images are linked by thumbnails some browsers only look in their cache
and don't request them too, but I digress.

Comment 5

17 years ago
When I select 'Save Page As...' from the toolbar or the rightclick menu, nothing
happens.
CT -- the bug you describe (with bookmarklet-generated pages) is fixed in
current trunk builds....
Blocks: 115634

Comment 7

16 years ago
Re: #6

Not in latest 2002062304 or latest-trunk 2002062408 I just upgraded to.. Maybe I
need to make a new profile. :/

Comment 8

16 years ago
On Windows ME:
1. Uninstall Mozilla
2. Reboot
3. Install Mozilla trunk 2002070504, creating a new test profile
4. Go to http://easyweb.easynet.co.uk/~aburnham/thumbs/page1.html
5. Use the linked images bookmarklet mentioned above
6. Try to save the newly generated page
7. Verify nothing happens.

Comment 9

16 years ago
Found a workaround: Choose Edit Page instead of Save As and save it in Composer.

Comment 10

16 years ago
I think it's very likely that this is a duplicate of Bug 158598 - I got the same
JavaScript Console error as in 158598 when I selected Save As on the linked
images bookmarklet page.

Comment 11

16 years ago
Re: comment 10

Ed, you're right! I changed my linked images bookmarklet to

javascript:(function(){var x,z,i; function linkIsSafe(u) { if
(u.substr(0,7)=='mailto:') return false; if (u.substr(0,11)=='javascript:')
return false; return true; } function linkIsImage(u) { var spd, ext;
spd=u.split('.'); if (spd.length > 0) { ext = spd[spd.length-1].toLowerCase();
if (ext=='gif' || ext=='jpg' || ext=='png' || ext=='mng') return true; } return
false; } function
htmlEscape(s){s=s.replace(/&/g,'&amp;');s=s.replace(/>/g,'&gt;');s=s.replace(/</g,'&lt;');return
s;} z = window.open().document; z.writeln('<html><head><title>Linked
Images</title></head><body><p>Images linked to by ' + htmlEscape(location.href)
+ ':</p><hr>'); x = document.links; for (i = 0; i < x.length; ++i)
if(linkIsSafe(x[i].href) && linkIsImage(x[i].href)) z.writeln('<p>' +
x[i].innerHTML + ' (' + htmlEscape(x[i].href) + ')<br><img src="' +
x[i].href.replace(/"/g, '&quot;') + '"></p>'); z.writeln('<hr></body></html>');
z.close(); })();

and it worked. Thanks!

Updated

16 years ago
No longer blocks: 115634

*** This bug has been marked as a duplicate of 158598 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.