Many mails to move to a folder from search (drag-drop) can lock TH and overload computer

RESOLVED DUPLICATE of bug 720158

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 720158
a year ago
a year ago

People

(Reporter: TREMBLAY,Bernard, Unassigned)

Tracking

({perf})

49 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bulkoperations])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Circumstances :
After a computer failure (hardware default), I had to restart an installation of thunderbird (the old profiles can be restored but the size with the archives is not compatible with the temporarily used computer).
So, I have limited to 100days the synchro with several IMAP accounts. 
No filter created, while a filter is set in "normal" profile.
One of those accounts have received near 15,000 messages (receives all exchanges from tiki-wiki, is saying near 200 mail per day).

Action : search for "tiki" and try (kamikaze) to move the 10,000 messages found with drag and drop to a new folder


Actual results:

The script hangs : bdtoolbar/content/bdToolbar5.js:257
First of all : intense usage of CPU (but a simple dual core)
The script asks for continuing (several time)
Later TH not responding for some spans of time
I could not order "continue" at script
This locks a core of the processor and TH doesn't answers anymore (since more than 20 mn)


Expected results:

May be, messages indicating :
- too many messages, please split the list
- allow stop (not cancel) task before the hang
- script overloaded : stop and restart moving remaining messages later
- change task priority and lock folders till the task is ended or stopped
(Reporter)

Comment 1

a year ago
Hi,

Twenty minutes more, the task stops locking TH, then we reach the "continue or stop script". I have stopped it (in fact a not clean cancel) the end ?, but :
- index and/or search on top inbox folder, are wrong :
   - many messages remains into top folder of inbox
   - "search" doesn't find these message : old and new, just one (without known particularity)

- need to rebuild indexes...

note : when job of the script is ended an upgrade from/to the IMAP begins with the target folder (download of headers) and update contents.

best regards

trebly
sounds like bug 720158
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Keywords: perf
Resolution: --- → DUPLICATE
Whiteboard: [bulkoperations]
Duplicate of bug: 720158
You need to log in before you can comment on or make changes to this bug.