Closed Bug 1315651 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::HTMLCanvasElement::GetCompositorBackendType

Categories

(Core :: Graphics, defect, P1, critical)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: marcia, Assigned: milan)

Details

(Keywords: crash, regression, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-f210c189-bb1b-456c-bff8-647b82161107.
=============================================================

Seen while looking at Nightly Fennec crash stats: http://bit.ly/2fxfMic. Small volume crash that started with build 20161106030203
I also see two crashes in the 20161105030211 build.

Milan, could this be a regression from bug 1309913? That is in the same time window, and touched the files that are crashing.
Flags: needinfo?(milan)
Keywords: regression
Most likely.  Looking at it now.
Assignee: nobody → milan
Flags: needinfo?(milan)
Priority: -- → P1
Whiteboard: [gfx-noted]
Jamie, is this a startup crash on any of the devices you have?
Flags: needinfo?(jnicol)
Comment on attachment 8808251 [details]
Bug 1315651: Check for null layer manager - we could be asking about the layer backend without it being there.

https://reviewboard.mozilla.org/r/91092/#review90874
Attachment #8808251 - Flags: review?(gwright) → review+
Pushed by msreckovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d01138a95d9
Check for null layer manager - we could be asking about the layer backend without it being there. r=gw280
Guessing the above commit will fix it, but no I couldn't reproduce this on my nexus 5x. tried going to a canvas page, opening/closing tabs, rotating screen, minimising app, etc. Under what circumstances would we expect the layer manager to be null?
Flags: needinfo?(jnicol)
Thanks for testing, and a valid question.  Perhaps a race condition?
https://hg.mozilla.org/mozilla-central/rev/1d01138a95d9
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.