Convert devtools CSS files to be loaded as resource://

RESOLVED DUPLICATE of bug 1311541

Status

defect
RESOLVED DUPLICATE of bug 1311541
3 years ago
10 months ago

People

(Reporter: jdescottes, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox52 affected)

Details

(Reporter)

Description

3 years ago
After Bug 1311178 landed, light-theme.css contains the following import statements:

> @import url(resource://devtools/client/themes/variables.css);
> @import url(resource://devtools/client/themes/common.css);

When loading light-theme.css in a content tab, the imports will fail. For devtools-html it would be nice if we could rely only on relative imports in our CSS files.

As I understand from the comments in Bug 1311178, this means we should make sure all our stylesheets are always requested as resource:// urls in the first place.
(Reporter)

Comment 1

3 years ago
(In reply to Julian Descottes [:jdescottes] from comment #0)
> 
> As I understand from the comments in Bug 1311178, this means we should make
> sure all our stylesheets are always requested as resource:// urls in the
> first place.

jryans, just want to make sure I'm not missing something before I start working on this, so let me know what you think.
I will probably clean up the loading of theme files first to unblock the devtools-html bugs.
Flags: needinfo?(jryans)
See Also: → 1311178

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1311541
Whiteboard: [devtools-html] [triage]
Replied in bug 1311541.
Flags: needinfo?(jryans)

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.