Crash when opening About > Help after enabling "Block other content trackers" and "Block Web fonts"

RESOLVED FIXED

Status

Focus-iOS
General
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: cpeterson, Assigned: bnicholson)

Tracking

({crash, reproducible})

Details

(Whiteboard: [MobileAS])

(Reporter)

Description

a year ago
STR:
1. Open Firefox Focus build #208
2. Open Settings
3. Enable "Block other content trackers"
4. Enable "Block Web fonts"
5. Open About > Help

RESULT:
CRASH! I have reproduced this crash five times using this STR.

I am running iOS 10.1.1 on iPhone 6s.
(Reporter)

Updated

a year ago
See Also: → bug 1315687
I could reproduce this bug by flipping settings on/off randomly.
(Assignee)

Comment 2

a year ago
I think I found the cause: viewDidLoad is called immediately after initialization, but we were assuming that it was called only after the view was added to the window. Since we load the web view with the URL viewDidLoad, we had a race where the URL may or may not have been set by the time viewDidLoad was called.

I can't reproduce, so please reopen if the next build doesn't fix this for you!

master: a1e31c0247ae33ed05a32a9f40bd0c34e1afce92
Assignee: nobody → bnicholson
Status: NEW → RESOLVED
Iteration: --- → 1.8
Last Resolved: a year ago
Priority: -- → P1
Resolution: --- → FIXED
Whiteboard: [MobileAS]
Possibly related (might be worth a separate bug, I'll wait for the next build) but trying to reproduce this I'm able to push a couple about views onto the stack. 

STR: Basically toggle some settings until you see the wave animation stutter and then quickly tap the "about" button multiple times. Several views will be added. Go back to the settings and do this randomly a few times and eventually the app will crash (should be a couple of stack traces in bb in the last 5 minutes or so from this post).

So I would think:

1. The wave animation shouldn't slow down from toggling any settings (is it saving state or something?)
2. You shouldn't be able to push multiple about views
3. The app shouldn't crash due to the above
You need to log in before you can comment on or make changes to this bug.