Status

SeaMonkey
General
--
blocker
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Brad Smith, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I updated mozilla to 0.99 from RedHat rawhide on a RedHat 7.2 system. Mozilla
was working well before. Mozilla failed to start. I tried as a user and as root.
The following processes are found even though mozilla fails to start:

bgsmith  24801 26.0  2.5 28340 13064 ?       S    10:34   0:00
/usr/lib/mozilla/mozilla-bin
bgsmith  24853  0.0  0.0     0    0 ?        Z    10:34   0:00 [mozilla-bin
<defunct>]
bgsmith  24854  0.0  2.5 28340 13064 ?       S    10:34   0:00
/usr/lib/mozilla/mozilla-bin
bgsmith  24855  0.0  2.5 28340 13064 ?       S    10:34   0:00
/usr/lib/mozilla/mozilla-bin
bgsmith  24856  0.0  2.5 28340 13064 ?       S    10:34   0:00
/usr/lib/mozilla/mozilla-bin

This has been a problem with every version of mozilla after 0.95. I have tried
them all. Sometimes the version in Rawhide will function. Sometimes nightly
builds will function, but none of the formal releases (0.96, 0.97, 0.98, 0.99)
work on this system. I can reinstall 0.95 from rpms to regain a functional mozilla.

I experimented early on and found that if I eliminated .mozilla then mozilla
would start. But then I loose all bookmarks (not a good thing). If I add the
saved bookmark file, mozilla will once again fail.

Comment 1

16 years ago
can you export the bookmarks (with a recent nightly build that works) and then
import them into a clean profile?
(Reporter)

Comment 2

16 years ago
I have mozilla-2002031609_trunk-0_rh7 currently installed. I moved .mozilla to
.moz and tried to start mozilla. Five processes were created but mozilla did not
display. Basically the same as above, except that the second process never gets
labelled as defunct.
You mean that it works without your bookmakrs file ?
Reporter (Brad Smith), please can you check to see whether this bug is still
present in a recent build
(Moz1-RC1 or a new nightly build). If this bug does not occur please can you
resolve it worksforme.
(Reporter)

Comment 5

16 years ago
I downloaded the rc1 rpms and installed them. Mozilla fails to start. It leaves
5 processes which I have to kill manually (kill -9). Netscape 6.2.2 for linux
works well on this system. I also tried the latest rpms from RedHat rawhide.
Same problem.

Comment 6

16 years ago
If only a single user is seeing this issue, it is more likely a problem with his
system than with Mozilla. Unless we see other suers reporting the same, this has
to be marked WORKSFORME, since it's apparently irreproducible without copying
Brad's entire system.
(Reporter)

Comment 7

16 years ago
Addendum. I finally found that the plugin directory for mozilla had Java plugins
from both Sun and IBM. I do a lot of Java development and use both JVMs for
testing and development. At somepoint links to both plugins were created in the
plugin directory. I removed the link to the IBM plugin and mozilla resumed
normal operation.

I hope this follow-up post is useful for someone else with the same problem.

Brad Smith
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.