Closed Bug 1316062 Opened 3 years ago Closed 3 years ago

D3D11 Hardware H264 Decoding broken with GPU process enabled (falls back to D3D9 instead)

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1314803
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 - fix-optional
firefox53 --- fix-optional

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: regression)

[Tracking Requested - why for this release]: Video playback regression with Quantum Compositor enabled.

Bisected with mozregression down to bug 1314133. I'm now getting "Yes; Failed to create D3D11 device for decoder; Using D3D9 API" for Hardware H264 Decoding when I used to get "Yes; Using D3D11 API".

Graphics
--------
Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics P530 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics P530 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; Failed to create D3D11 device for decoder; Using D3D9 API
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.14393.351)
GPU #1
Active: Yes
Description: Intel(R) HD Graphics P530
Vendor ID: 0x8086
Device ID: 0x191d
Driver Version: 21.20.16.4541
Driver Date: 10-20-2016
Drivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Subsys ID: 06d91028
RAM: Unknown
GPU #2
Active: No
Description: NVIDIA Quadro M1000M
Vendor ID: 0x10de
Device ID: 0x13b1
Driver Version: 21.21.13.7563
Driver Date: 10-21-2016
Drivers: C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvdmwi.inf_amd64_c2a31e8d3f813a51\nvwgf2um
Subsys ID: 06d91028
RAM: 2048
Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: cairo
GPUProcessPid: 11964
GPUProcess: Terminate GPU Process
failures: CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default

Failure Log
(#0): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#1): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#2): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#3): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#4): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#5): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#6): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#7): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
(#8): CP+[GFX1]: Potential driver version mismatch ignored due to missing DLLs 0.0.0.0 and 0.0.0.0
Flags: needinfo?(dvander)
Hmm, maybe a dupe of bug 1314803.
You may need multiple prefs set to get GPU decoding enabled in this config.
Flags: needinfo?(matt.woodrow)
Yep, this is bug 1314803, it's just a reporting problem.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(dvander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1314803
Tracking 52-. Will track in the dupe bug.
Tweaking the flags to get this off the radar for engineering/relman triage.
You need to log in before you can comment on or make changes to this bug.