Crashed clicking on a folder while deleting a message [@ nsSupportsArray::Clear]

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: David Bradley, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020227
BuildID:    20020315

I was deleting a message and then clicked on a folder. When I clicked on the
flder it crashed. It was either still deleting the message, or was displaying
the second message when I clicked on the folder.

Stack trace to follow.

Reproducible: Couldn't Reproduce
(Reporter)

Comment 1

16 years ago
Created attachment 74640 [details]
Stack trace

The cash occured in a call to the first element in the array during
destruction. So it looks like, either the array was already deleted, or the
first element was already deleted.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 2

11 years ago
david, did you ever see this again? 

many nsSupportsArray bugs have been closed since your report including bug 141864,  bug 264935, bug 234620  specific to nsSupportsArray::Clear and one still open bug 155497. No crashers on talkback.
Severity: normal → critical
Keywords: crash
QA Contact: esther
Summary: Crashed clicking on a folder while deleting a message → Crashed clicking on a folder while deleting a message [@ nsSupportsArray::Clear]
(Reporter)

Comment 3

11 years ago
I haven't seen this crash since, I'd say lets mark it can't reproduce and move on.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsSupportsArray::Clear]
You need to log in before you can comment on or make changes to this bug.