[css-flexbox] justify-content does not respect absolutely positioned children

RESOLVED DUPLICATE of bug 1269045

Status

()

defect
RESOLVED DUPLICATE of bug 1269045
3 years ago
3 years ago

People

(Reporter: mattijs, Unassigned)

Tracking

({testcase})

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36

Steps to reproduce:

1. Set display: flex and justify-content: space-between on parent element.
2. Set position: absolute on one of the child elements

See reduced test case here: http://jsbin.com/dawoyaqaki/edit?css,output


Actual results:

The absolutely positioned child element is accounted for in the spacing of the child elements.


Expected results:

If I understand the spec correctly, the child element should have been ignored. See here:
https://www.w3.org/TR/css-flexbox-1/#abspos-items

Updated

3 years ago
Component: Untriaged → Layout
Product: Firefox → Core
I think this has been fixed in the latest Nightly:  https://nightly.mozilla.org/
(in bug 1269045)
Keywords: testcase
Summary: justify-content does not respect absolutely positioned children → [css-flexbox] justify-content does not respect absolutely positioned children

Comment 2

3 years ago
Indeed. Fix range: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b48820f4c87aeaa2186c401c1bafe6661d6b7e31&tochange=995211b23a553e1518e8c79570d27f5c4fd0bb86
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269045
You need to log in before you can comment on or make changes to this bug.