Closed Bug 1316373 Opened 3 years ago Closed 3 years ago

Blackboard, Inc.

Categories

(Firefox Graveyard :: Screen Sharing Whitelist, defect)

All
Other
defect
Not set

Tracking

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: carl.marrelli, Assigned: drno)

Details

Attachments

(1 file)

>> Vendor name
Blackboard, Inc.

>> Point of contact
Carl Marrelli

>> Site URLs
*.bbcollab.com

>> Does the application provide users with notice and control?
Yes.  Blackboard Collaborate prompts the user to ask if they want to share the whole desktop or an individual application.  This control is accessible to keyboard and screen readers.  Screen sharing only shares content based on this selection and is limited to the intended participants by restricting the stream to the active webrtc call.  The feature is under the direct control of the end user at all times.

This feature is documented in our online Help here: https://en-us.help.blackboard.com/Collaborate/Ultra/Moderator/030_Share_Content#section_1

*.bbcollab.com is requested as our application is hosted in multiple regions.



>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes
Hello.  We have a release that depends on this being resolved.  Can we please get an update?  

Thanks!
+ on approval for whitelist.
Flags: needinfo?(mreavy)
Comment on attachment 8811022 [details]
Bug 1316373: add Blackboards domains to screenshare whitelist.

Thanks, Shell.  

Randell -- Can you please land this for me?  Nils or I will ask for uplift to Fx52 and Fx51 after it has merged to central.  Thanks.
Flags: needinfo?(mreavy) → needinfo?(rjesup)
Attachment #8811022 - Flags: review?(mreavy) → review+
Assignee: nobody → drno
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi Carl -- The patch will land in Fx53 today.  I expect it to be in Beta (Fx51) before the end of this month (November).
Flags: needinfo?(carl.marrelli)
Comment on attachment 8811022 [details]
Bug 1316373: add Blackboards domains to screenshare whitelist.

https://reviewboard.mozilla.org/r/93270/#review93562
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/eca45b922a55
add Blackboards domains to screenshare whitelist. r=mreavy
Thank you all very much.  I have a quick question to help inform my team and our customers.  Which version of Firefox introduced the whitelist?  Will Fx49 and Fx50 users not be able to use the extension?  Are our customers limited to Fx51+ ?
(In reply to Carl Marrelli from comment #8)
> Thank you all very much.  I have a quick question to help inform my team and
> our customers.  Which version of Firefox introduced the whitelist?  Will
> Fx49 and Fx50 users not be able to use the extension?  Are our customers
> limited to Fx51+ ?

We can only request the white list change to get included up to Fx51. So users with Fx <= 50 will not have the Blackboard domains in their white list. If you want to support users with Fx <= 50 the only option I see is that Blackboard would to write a Firefox Add-on, which then adds the Blackboard domains to the white list. The Add-on approach would work for any version of Fx since it supports screen sharing.
Thanks, Nils.  Is the release date for Fx51 correct here? https://blog.mozilla.org/futurereleases/2016/02/04/update-on-2016-firefox-release-schedule/
(In reply to Carl Marrelli from comment #10)
> Thanks, Nils.  Is the release date for Fx51 correct here?
> https://blog.mozilla.org/futurereleases/2016/02/04/update-on-2016-firefox-
> release-schedule/

Yes that seems to match the page I usually check, which is https://wiki.mozilla.org/RapidRelease/Calendar
https://hg.mozilla.org/mozilla-central/rev/eca45b922a55
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8811022 [details]
Bug 1316373: add Blackboards domains to screenshare whitelist.

Approval Request Comment
[Feature/regressing bug #]: screensharing whitelist
[User impact if declined]: Blackboards product launch for Firefox is blocked by this.
[Describe test coverage new/current, TreeHerder]: manually verified (it's a text only change)
[Risks and why]:  Extremely low risk, very easily verified, pref only change. 
[String/UUID change made/needed]: N/A
Attachment #8811022 - Flags: approval-mozilla-beta?
Attachment #8811022 - Flags: approval-mozilla-aurora?
Comment on attachment 8811022 [details]
Bug 1316373: add Blackboards domains to screenshare whitelist.

Support Blackboard screesharing. Beta51+ and Aurora52+. Should be in 51 beta 2.
Attachment #8811022 - Flags: approval-mozilla-beta?
Attachment #8811022 - Flags: approval-mozilla-beta+
Attachment #8811022 - Flags: approval-mozilla-aurora?
Attachment #8811022 - Flags: approval-mozilla-aurora+
has problems to apply to beta:

grafting 375439:20d6c664a89e "Bug 1316373: add Blackboards domains to screenshare whitelist. r=mreavy, a=gchang"
merging modules/libpref/init/all.js
warning: conflicts while merging modules/libpref/init/all.js! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(drno)
https://hg.mozilla.org/releases/mozilla-beta/rev/4a50f24275d4
Flags: needinfo?(rjesup)
Flags: needinfo?(drno)
Flags: needinfo?(carl.marrelli)
[bugday-20170104] Bug verified
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.