Emoji icons showing up as boxes with codes inside them

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: parker.seaman, Unassigned)

Tracking

53 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8809427 [details]
screenshot of the issue I'm having

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161110002945

Steps to reproduce:

view this copy pasta: https://t.co/dqVeYhVCHm
read the copy pasta


Actual results:

the copypasta's emoji's did not display correctly/did now show icons.


Expected results:

Should have propperly displayed the icons
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
Created attachment 8810785 [details]
Screenshot from 2016-11-15 11-44-11.png

User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID 	20161114043454

I couldn't reproduce this issue on Linux x86_64 using Firefox Nightly and Firefox 50 Release. Please note that I used a new profile without add-ons.
Please see the screenshot attached.

Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

If you still have the issue please create a new profile, you have the steps here: 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager
Flags: needinfo?(parker.seaman)
(Reporter)

Comment 2

2 years ago
(In reply to Hani Yacoub from comment #1)
> Created attachment 8810785 [details]
> Screenshot from 2016-11-15 11-44-11.png
> 
> User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101
> Firefox/53.0
> Build ID 	20161114043454
> 
> I couldn't reproduce this issue on Linux x86_64 using Firefox Nightly and
> Firefox 50 Release. Please note that I used a new profile without add-ons.
> Please see the screenshot attached.
> 
> Please test if the issue can be reproduced in the safe mode of Firefox:
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 
> Please download the Firefox Nightly from here: https://nightly.mozilla.org/
> and retest the problem.
> 
> If you still have the issue please create a new profile, you have the steps
> here: 
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles?redirectlocale=en-US&redirectslug=Managing-
> profiles#w_starting-the-profile-manager

I created a new profile as well as starting in safe mode, yet I still have the same issue. I also changed my content settings to allow sites to choose their own fonts, but no dice.
Component: Untriaged → General

Updated

2 years ago
Component: General → Untriaged
(Reporter)

Updated

2 years ago
Flags: needinfo?(parker.seaman)
(Reporter)

Updated

2 years ago
Version: 52 Branch → 53 Branch

Comment 3

2 years ago
I am facing the same issue, but with version 50 on a 64 bit Lubuntu machine. I thought that Firefox should render emojis even if my native OS does not support them.

Comment 4

2 years ago
Sorry, let me clarify, Firefox renders emojis, like on the first picture which was taken on the 10th of November. There are lots of scare boxes with numbers in them.

Comment 5

2 years ago
Same thing with
Linux Mint 18 with firefox 50.0 64bit

here I have old awfull emojis and square box http://getemoji.com/

Updated

2 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.