Background image displayed wrong

RESOLVED DUPLICATE of bug 115046

Status

()

Core
Layout
P2
major
RESOLVED DUPLICATE of bug 115046
16 years ago
16 years ago

People

(Reporter: Markus Hübner, Assigned: Marc Attinasi)

Tracking

({regression})

Trunk
Future
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Recent regression - http://www.payplus.at/intro.asp is having the background 
image displayed wrong.
Just see the background image included at http://www.payplus.at/imgs/bg1.gif

build 2002031608 on win-xp
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0, nsbeta1, regression

Comment 1

16 years ago
Confirming on Linux 2002031721 compared to 0.9.9.
OS: Windows 2000 → All
Looks identical here in Mozilla current trunk and Netscape 4.

Could you attach a pair of screenshots demonstrating the bug?

Comment 3

16 years ago
Can't connect the server at the moment so no screenshots for now. Be sure you're
window is large enough, the background is only truncated on the right side of
the page.
how wide is wide enough?  It looks fine with a 1280px-wide window...

Comment 5

16 years ago
Wide enough. As soon as I come through to the austrian telecom server again,
I'll attach two screenshots.

Comment 6

16 years ago
Created attachment 74743 [details]
Screenshot showing the bug in a nightly.

Just realized, that resizing the window makes the bug go away.

Comment 7

16 years ago
Created attachment 74744 [details]
Screenshot of 0.9.9.

Comment 8

16 years ago
Hm, there's no scrollbar either.

Comment 9

16 years ago
looks like layout. the <div id="content"> shows up as an empty frame on the
right in document inspector. The children are back in the <div id="contentClip">
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future
(Reporter)

Comment 10

16 years ago
How can this regression be futured?!

Comment 11

16 years ago
I think this is because, there is start of table tag in the body which ends 
encapsulating  all the other data. The div tags do appear within this table but 
are not encapsulated within any <td> tag.
(Assignee)

Comment 12

16 years ago
This is another no-scrolling problem. remove the overflow:hidden from teh body's
style and it works fine. This regressed because I recently put in support for
overflow:hidden and that exposed this. It is also why there are no scrollbars :)

This is the exact same problem as the 'scrolling=no / overflow:hidden' bugs we
have, for examples see bug 124431.
Status: NEW → ASSIGNED
(Assignee)

Comment 13

16 years ago
This is propbably a direct dup of bug 116723, actually.
Depends on: 116723

Comment 14

16 years ago
If it is actually a duplicate of bug 116723 :
- you should change component to HTMLFrames or mark it as RESOLVED DUPLICATE.
- why the mozilla1.0 keyword is in this bug and not in 116723 ?

Also, I have no problem with that background in Mozilla 0.9.9 (#2002031104
Windows 2000).
> Also, I have no problem with that background in Mozilla 0.9.9

See comment 12, end of first paragraph.  Another recent bugfix made "overflow: 
hidden" work on <body> and <html> (it used to be ignored) and triggered this bug 
(which may be a duplicate of the generic "overflow:hidden on root element is 
broken" bug and is marked a dependency of that bug for now).
nsbeta1-. Engineers are overloaded with higher priority bugs, although this may
be fixed when bug 124431 (nsbeta1+) is fixed.
Keywords: nsbeta1 → nsbeta1-

Updated

16 years ago
No longer depends on: 116723
Dup of bug 115046, as evidenced by the fact that it is fixed with bug 119849.

*** This bug has been marked as a duplicate of 115046 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Depends on: 124431
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.