Closed Bug 1316783 Opened 3 years ago Closed 3 years ago

[e10s] box-shadow is incorrectly tiled when printed

Categories

(Core :: Printing: Output, defect, P1)

50 Branch
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox49 --- unaffected
firefox-esr45 --- unaffected
firefox50 + fixed
firefox51 + fixed
firefox52 + fixed
firefox53 --- fixed

People

(Reporter: the.decryptor, Assigned: bobowen)

References

(Blocks 1 open bug, )

Details

(Keywords: multiprocess, regression)

Attachments

(2 files, 1 obsolete file)

I can reproduce this on OS X and Windows with the latest Nightly (As well as one from about a week ago), trying to print the linked page shows the shadows in the "Live examples" section being tiled instead of displayed normally.

Both text-shadow and drop-shadow() display fine, the issue's only with box-shadow.
[Tracking Requested - why for this release]: Print output is broken against box-shadow

Reproduce on Windows10 Nightly52.0a1, Aurora51.0a2 and 50.0rc2.
Not reproduce on Windows10 49.0.2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: Trunk → 50 Branch
Disable e10s seems to fix the box-shadow problem.
Keywords: multiprocess
Summary: box-shadow is incorrectly tiled when printed → [e10s] box-shadow is incorrectly tiled when printed
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa802cc2231d1933e64c2e27fcbcd17394563891&tochange=69e6782758af0cccc4cfd4bae482e4d5c61ff0da

Regressed by: 69e6782758af	Bob Owen — Bug 1156742 Part 25: Flip the big switch and wait for the lightning. r=mconley
Blocks: 1156742
Flags: needinfo?(bobowencode)
Blocks: 925570
Blocks: fxe10s
Track 51+/52+ as regression related to print output.
Confirmed the issue is related to e10s and can be avoided when setting 'print.print_via_parent' to false.
After talking to GFX team Ethan Lin, there might be a problem when recording draw commands for box-shadow to  printing DrawTarget.
Priority: -- → P1
I think I found the problem.

Looks like it doesn't record the mSamplingRect for the pattern used to extend the shadow.
Assignee: nobody → bobowencode
Status: NEW → ASSIGNED
Flags: needinfo?(bobowencode)
MozReview-Commit-ID: 8JWzW2cOSXK
MozReview-Commit-ID: 8JWzW2cOSXK
Attachment #8810386 - Flags: review?(mstange)
Attachment #8810347 - Attachment is obsolete: true
Attachment #8810386 - Flags: review?(mstange) → review+
We can uplift this fix to 50.1.0 if deemed safe. Andrew Overholt and I have reviewed this bug. It isn't release blocking for 50.0 go live.
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e267219153d
Record mSamplingRect for PatternType::SURFACE when using DrawTargetRecording. r=mstange
https://hg.mozilla.org/mozilla-central/rev/0e267219153d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Please request Aurora/Beta approval on this when you get a chance. And Release if you think it's worth trying to get into December's 50.1 release.
Flags: needinfo?(bobowencode)
Comment on attachment 8810386 [details] [diff] [review]
Record mSamplingRect for PatternType::SURFACE when using DrawTargetRecording

Approval Request Comment
[Feature/regressing bug #]:
Bug 1156742 (which uncovered an existing issue in the DrawTargetRecording).

[User impact if declined]:
box-shadow will continue to print incorrectly. 

[Describe test coverage new/current, TreeHerder]:
Manual testing only. Tested with MDN page from bug report and two example pages linked from that page:
https://developer.mozilla.org/en-US/docs/Web/CSS/box-shadow
http://www.elektronotdienst-nuernberg.de/bugs/box-shadow_inset.html
http://markusstange.wordpress.com/2009/02/15/fun-with-box-shadows/

[Risks and why]:
low - fairly simple change to record the extra parameter required. The only concern is the lack of automated testing.

[String/UUID change made/needed]:
None
Flags: needinfo?(bobowencode)
Attachment #8810386 - Flags: approval-mozilla-release?
Attachment #8810386 - Flags: approval-mozilla-beta?
Attachment #8810386 - Flags: approval-mozilla-aurora?
Comment on attachment 8810386 [details] [diff] [review]
Record mSamplingRect for PatternType::SURFACE when using DrawTargetRecording

Fix an issue related to printing. Beta51+ and Aurora52+. Should be in 51 beta 2.
Attachment #8810386 - Flags: approval-mozilla-beta?
Attachment #8810386 - Flags: approval-mozilla-beta+
Attachment #8810386 - Flags: approval-mozilla-aurora?
Attachment #8810386 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Hello Alex, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(the.decryptor)
Oh sorry, it's working fine now on everything I've tested with.
(In reply to Alex from comment #18)
> Oh sorry, it's working fine now on everything I've tested with.

Thanks!
Status: RESOLVED → VERIFIED
Comment on attachment 8810386 [details] [diff] [review]
Record mSamplingRect for PatternType::SURFACE when using DrawTargetRecording

Recent regression in 50, this wasn't deemed release blocking but it seems to be a good bug to fix in 50.1.0
Attachment #8810386 - Flags: approval-mozilla-release? → approval-mozilla-release+
(In reply to Alex from comment #18)
> Oh sorry, it's working fine now on everything I've tested with.

It seems that no additional qa work is needed here. Removing flag.
Flags: qe-verify+
Flags: needinfo?(the.decryptor)
You need to log in before you can comment on or make changes to this bug.