Closed Bug 1316833 Opened 3 years ago Closed 3 years ago

"JSON" tab is empty under "Params" if sending to 404

Categories

(DevTools :: Netmonitor, defect)

50 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1309243

People

(Reporter: nachtigall, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot.png
STR:
I've made a minimal example you can view at http://codepen.io/nachtigall/pen/QGyBZj (full view, better for devtools at http://codepen.io/nachtigall/full/QGyBZj/)

Code is just:

fetch('https://developer.mozilla.org/this-gives-404', {
  method: 'post',
  body: JSON.stringify({
    someProperty: 'Prop that we send. This should be visible'
  })
});

The console view with "net" shows the JSON being sent correctly. However, the netmonitor just has an empty JSON giving the impression that nothing has been send. See Screenshot.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309243
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.