Parsing a .ini file with Windows line endings returns Junk

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: flod, Assigned: Pike)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8809845 [details]
updater.ini

It happened with the attached file while testing the l20n migration script.

The .val I get for Junk is _junk_8_247-248, haven't checked if the rest of the file is read properly
(Reporter)

Comment 1

2 years ago
Looking at the output of the Transvision testing branch, it reads the values, with a weird new line at the end

'suite/updater/updater.ini:InfoText' => '%MOZ_APP_DISPLAYNAME% sta installando gli aggiornamenti e si avvierà fra qualche istante…
',

'suite/updater/updater.ini:TitleText' => 'Aggiornamento %MOZ_APP_DISPLAYNAME%
',
Comment hidden (mozreview-request)
(Reporter)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8809880 [details]
bug 1316880, make line-ending handling universal universially,

https://reviewboard.mozilla.org/r/92380/#review92406

Thanks, it works great. Only nit: typo in the commit message ;-)
Attachment #8809880 - Flags: review?(francesco.lodolo) → review+
(Reporter)

Updated

2 years ago
Assignee: nobody → l10n
(Assignee)

Comment 4

2 years ago
https://hg.mozilla.org/l10n/compare-locales/rev/bc436e6748c408fde110a6de5952d19c1478fc33, FIXED.

Also edited the commit message.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.