Fatal performance in Facebook comments

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: michalwadas, Unassigned)

Tracking

(Blocks: 1 bug)

49 Branch
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [qf:p1][platform-rel-Facebook])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8809881 [details]
profile.json

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Opened this photo: https://www.facebook.com/events/1837232359839359/permalink/1857011521194776/ (warning: lot of hate speech comments).
Clicked 10 times on "view more comments".

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0.

Hardware: i5 6600, GTX 960, 16GB RAM. 

Reproducible on Ubuntu with i5-3xxx and integrated graphics.


Actual results:

Pages freezes for long time. Firefox builtin profiler reports 25% time spent in GC (8 seconds), 13% in Gecko and 7% in JIT. profile.json attached.

Tab seems to use at least 100MB (that much was released after closing tab).

Whole browser performance is severely degraded and scrolling that page is almost impossible.


Expected results:

It should probably work smoother.

Loading times aren't better on Chrome, but they have at least smooth scrolling afterwards.

Comment 1

2 years ago
Created attachment 8811246 [details]
warning unresponsive script.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161104212021

While trying to reproduce this bug on Windows 7 64 Bit using Firefox 50 Release, I observed that scrolling on the page is quite slow especially after many clicks on "View more comments". 
After clicking more than 10 times on "View more comments" a pop-up warning is displayed.
please see the screenshot attached.

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

2 years ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
Original photo was deleted, but issue can be reproduced with any heavy (few hundred comments) thread on Facebook.
platform-rel: --- → ?
Whiteboard: [platform-rel-Facebook]

Updated

2 years ago
Blocks: 1288602
platform-rel: ? → -
Whiteboard: [platform-rel-Facebook] → [qf:p1][platform-rel-Facebook]
I just tried to reproduce this with Nightly 20170323030203 [Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0] on Win10, but I can't. The page I opened was:

  https://www.facebook.com/ScienceNaturePage/videos/1035330013265923/?hc_ref=NEWSFEED

which has 855 comments, I loaded 600 of them but the browser still scrolls smoothly.
Need QA to double check whether this can be reproduced.
Keywords: qawanted
Thanks for reporting. While waiting for QA's response, I'd like to know do you still have the same issue with the latest release?
Flags: needinfo?(michalwadas)
(Reporter)

Comment 6

2 years ago
I wasn't able to reproduce it in similar circumstances.
Flags: needinfo?(michalwadas)
WFM because it's not reproducable.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.