Figure out how to integrate new layer types to WebRenderLayerManager

RESOLVED DUPLICATE of bug 1313703

Status

()

Core
Graphics: WebRender
P3
normal
RESOLVED DUPLICATE of bug 1313703
a year ago
a year ago

People

(Reporter: kats, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

(Whiteboard: [gfx-noted])

The plan going forward with WR integration is to expand the types/numbers of layers we generate on the content side until they sort of correspond to WR display items. At that point we can make the switch to just sending WR display items directly.

We should figure out a plan for doing this. Perhaps a good first step would be integrating Matt/Bas' work on text layers to the current WR branch and seeing how it fits in.
Actually this is the same as bug 1313703.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1313703
You need to log in before you can comment on or make changes to this bug.