Closed Bug 1316907 Opened 3 years ago Closed Last year

WebExtensions: Moving last tab out of window causes URLBarZoom.jsm errors and onZoomChange errors

Categories

(WebExtensions :: General, defect, P3)

52 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dw-dev, Unassigned)

Details

(Whiteboard: triaged)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161107030203

Steps to reproduce:

TEST SCENARIO A

1. Install Tile Tabs WE 5.1 - https://addons.mozilla.org/en-US/firefox/addon/tile-tabs-we/
2. Open a browser window
3. Create three tabs (all Wikipedia home page)
4. Click the Tile Tabs WE button to create a layout with two tiled browser windows, each containing one tab from the original browser window.
5. Click the Tile Tabs WE button in one of the two tiled browser windows, which closes both of the tiled browser windows by moving the last tab in each tiled browser window back into the original browser window.


TEST SCENARIO B

1. Install Tile Tabs WE 5.1 and Zoom Page WE 3.2 - https://addons.mozilla.org/en-US/firefox/addon/zoom-page-we/
2. Repeat steps A2 to A5.





Actual results:

TEST SCENARIO A

Tile Tabs WE uses chrome.tabs.move() to move the last tab out of each tiled browser window, which results in the following error message:

    TypeError: win is null[Learn More]        URLBarZoom.jsm:24:7

I suspect this error is due to the zoom change observer calling updateZoomButton() after the tiled browser window has closed.


TEST SCENARIO B

Zoom Page WE has a chrome.tabs.onZoomChange.addListener() listener, which results in the following additional error messages:

    Unchecked lastError value: Error: Invalid tab ID: 6        ExtensionUtils.jsm:399
        withLastError              resource://gre/modules/ExtensionUtils.jsm:399:9
        wrapPromise/<            resource://gre/modules/ExtensionUtils.jsm:450:11

I suspect these errors are due to the zoom change listener being called after the browser window has closed.

I have no idea where the invalid tab ID (6) comes from, since there are only three tabs in the original browser window.



Expected results:

TEST SCENARIO A

There should be no error messages.

TEST SCENARIO B

There should be no error messages.
It is a dupe of bug 1297970 which should be fixed by bug 1300376.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1297970
The bug I reported has a wider scope than bug 1297970 or bug 130076, both of which are focused on calls to updateZoomButton() - my 'Test Scenario A'.

As far as I can see, the fix for bug 1300376 does not address calls to chrome.tabs.onZoomChange listeners - my 'Test Scenario B'.

Please can you confirm whether 'Test Scenario B' is addressed by the fix for bug 1300376.
Flags: needinfo?(epinal99-bugzilla2)
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(epinal99-bugzilla2)
Resolution: DUPLICATE → ---
Let's reopen it and check when bug 1300376 will be fixed.
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Priority: -- → P3
Whiteboard: triaged
I will re-test when bug 1300376 is fixed.

I am pretty sure the changes for bug 1300376 will not fix my Test Scenario B.
de-dev: can you verify?
Flags: needinfo?(dw-dev)
I have repeated the Test Scenarios A & B, using Tile Tabs WE 5.1 and Zoom Page WE 3.2, and the error messages do not appear.

I have also repeated the Test Scenarios A & B, using the latest versions of my add-ons (Tile Tabs WE 9.2 and Zoom Page WE 10.4), and the error messages do not appear.

As far as I am concerned, this bug is fixed.
Product: Toolkit → WebExtensions
Bulk move of bugs per https://bugzilla.mozilla.org/show_bug.cgi?id=1483958
Component: Untriaged → General
Status: REOPENED → RESOLVED
Closed: 3 years agoLast year
Flags: needinfo?(dw-dev)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.