Combobox (single-line <select>) dropdowns no longer stay open after you release the mouse

RESOLVED DUPLICATE of bug 1316597

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 1316597
a year ago
a year ago

People

(Reporter: bz, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52- fixed)

Details

(URL)

[Tracking Requested - why for this release]: Regression in common user-facing UI.

BUILD: Current trunk Mac build

STEPS TO REPRODUCE:

1)  Load data:text/html,<select><option>click and release me; you should see the dropdown stay dropped down<option>Another option

2)  Follow the instructions in the testcase.

ACTUAL RESULTS: As soon as I let go of the mouse button, the dropdown closes.  I get all confused about why I can't select my options.

EXPECTED RESULTS: The dropdown should stay open.  That's what happens in Safari and Chrome, and with OS-native dropdowns

ADDITIONAL INFORMATION: The regression range on nightlies is https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f13e90d496cf1bc6dfc4fd398da33e4afe785bde&tochange=783356f1476eafd8e4d6fa5f3919cf6167e84f8d and I'm on Mac, so I bet this regressed with bug 430745.

Updated

a year ago
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316597
updating fx52 status flag per https://bugzilla.mozilla.org/show_bug.cgi?id=1316597#c7
status-firefox52: affected → fixed
tracking-firefox52: ? → -
You need to log in before you can comment on or make changes to this bug.