Closed Bug 1317144 Opened 3 years ago Closed 3 years ago

Ugly interface font rendering with e10s (electrolysis) enabled

Categories

(Core :: Graphics: Text, defect)

52 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1315568

People

(Reporter: z_mashine, Unassigned)

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Attached image build_06112016_2016-11-13_173658.png (obsolete) —
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161113030203

Steps to reproduce:

1. It is necessary to update to Nightly build on November 6 or later.
2. "Enable multi-process Nightly" option must be enabled.


Actual results:

Ugly interface font rendering with e10s (electrolysis) enabled.

If you disable e10s, the fonts in the interface look great.


Expected results:

The fonts in the interface must look great.
Attached screenshot taken on a clean profile.
Flags: needinfo?(z_mashine)
Keywords: fonts
Attachment #8810198 - Attachment is obsolete: true
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Attached image update-win7.png
It looks fine for me with the 64b version on Win 7. Maybe it's specific to Win 10.

Could you install the tool mozregression to narrow down a regression range.
See http://mozilla.github.io/mozregression/ for details.

Run the command "mozregresion --good=2016-11-05" then copy here the final pushlog from the repository mozilla-inbound.
Thanks for help!

I use Windows 8.1.

 7:58.36 INFO: Last good revision: c04f84afb1bd6b3ea372164012735de6c8f2d582
 7:58.36 INFO: First bad revision: b4ade2b0841c5825968f34752d86ee09507a0a9f
 7:58.36 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c04f84afb1bd6b3ea372164012735de6c8f2d582&tochange=b4ade2b0841c5825968f34752d86ee09507a0a9f

 7:59.49 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1314133
You can swap the pref layers.gpu-process.dev.enabled to false in about:config, font rendering should be like previously (restart Nightly to apply).

Could you copy here the "graphics" section of the page about:support, please.
Anyway I think your issue is already reported in bug 1315568.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(z_mashine)
Resolution: --- → DUPLICATE
Duplicate of bug: 1315568
> You can swap the pref layers.gpu-process.dev.enabled to false in about:config, font rendering should be like previously (restart Nightly to apply).

Yes, you are right.

>Could you copy here the "graphics" section of the page about:support, please.

Graphics
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	Yes; Using D3D11 API
Audio Backend	wasapi
Direct2D	true
DirectWrite	true (6.3.9600.17111)
GPU #1
Active	Yes
Description	NVIDIA GeForce GT 630
Vendor ID	0x10de
Device ID	0x1284
Driver Version	21.21.13.7570
Driver Date	10-25-2016
Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID	130819da
RAM	1024
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
Decision Log
HW_COMPOSITING	
force_enabled by user: Force-enabled by pref
D3D9_COMPOSITING	
disabled by default: Disabled by default
force_enabled by user: Hardware compositing is force-enabled
And with blurry fonts in interface:

Graphics
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer	Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	Yes; Failed to create D3D11 device for decoder; Using D3D9 API
Audio Backend	wasapi
Direct2D	true
DirectWrite	true (6.3.9600.17111)
GPU #1
Active	Yes
Description	NVIDIA GeForce GT 630
Vendor ID	0x10de
Device ID	0x1284
Driver Version	21.21.13.7570
Driver Date	10-25-2016
Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID	130819da
RAM	1024
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	cairo
GPUProcessPid	3568
GPUProcess	
Decision Log
HW_COMPOSITING	
force_enabled by user: Force-enabled by pref
D3D9_COMPOSITING	
disabled by default: Disabled by default
force_enabled by user: Hardware compositing is force-enabled
You need to log in before you can comment on or make changes to this bug.