Closed Bug 13172 Opened 21 years ago Closed 21 years ago

Scrolling with arrow keys doesn't work

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bscholl+, Assigned: mjudge)

References

()

Details

On Linux, scrolling with arrow keys doesn't work on some sites, such as http://www.freshmeat.net.  Pressing down scrolls down a bit, but the viewer subsequently jumps back up.  Scrolling with the scrollbars and pageup/pagedown works fine.
Assignee: troy → beard
Component: Layout → Compositor
Patrick, may be a widget problem as well. I don't know. It don't think it's a
layout problem, though
OS: Linux → All
Hardware: Other → All
this is happening with all builds as of the 19990907 builds. changing platform to
all and cc'ing ramirowho has bug 12854 which may be a dupe.
*** Bug 13244 has been marked as a duplicate of this bug. ***
*** Bug 12780 has been marked as a duplicate of this bug. ***
*** Bug 13369 has been marked as a duplicate of this bug. ***
Assignee: beard → mjudge
Component: Compositor → Event Handling
This is caused by dueling event code -- there are two interpretations of arrow
keys being used:  1. in nsRangeList.cpp (line 830) wants to scroll a DOM
selection into view, and 2. in nsEventStateManager.cpp which interprets arrow
keys as scrolling line by line. At a certain point in the document, these are in
conflict, and funny scrolling commences. Who should have precedence? You decide.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
i think this is cool now. you cant scroll in editable fields with arrow
keys. the only time i can see this is when the inner layout/view doesnt have
focus. i checked in some code before i think its been fixed from this.
Status: RESOLVED → VERIFIED
Fixed in the Sept 22nd Build.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.