Can't build aurora tip as artifact build (on merge day?)

RESOLVED DUPLICATE of bug 1306614

Status

()

RESOLVED DUPLICATE of bug 1306614
2 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
0:01.24 Adding client.mk options from /Users/gkruitbosch/dev/configs/aurora-artifact.mozconfig:
 0:01.24     MOZ_OBJDIR=/Users/gkruitbosch/dev/builds/aurora-artifact
 0:01.24     OBJDIR=/Users/gkruitbosch/dev/builds/aurora-artifact
 0:01.24     FOUND_MOZCONFIG=/Users/gkruitbosch/dev/configs/aurora-artifact.mozconfig
 0:02.41 Attempting to find a pushhead containing ebec82f380befccdb9653a607330835cd5f7b1be on mozilla-central.
 0:03.39 Attempting to find a pushhead containing ebec82f380befccdb9653a607330835cd5f7b1be on integration/mozilla-inbound.
 0:04.18 Attempting to find a pushhead containing ebec82f380befccdb9653a607330835cd5f7b1be on releases/mozilla-aurora.
 0:04.18 Retrieving the last 50 pushheads starting with id 10299 on releases/mozilla-aurora
 0:11.32 Error running mach:
 0:11.32 
 0:11.32     ['--log-no-times', 'artifact', 'install']
 0:11.32 
 0:11.32 The error occurred in code that was called by the mach command. This is either
 0:11.32 a bug in the called code itself or in the way that mach is calling it.
 0:11.32 
 0:11.32 You should consider filing a bug for this issue.
 0:11.32 
 0:11.32 If filing a bug, please include the full output of mach, including this error
 0:11.32 message.
 0:11.32 
 0:11.32 The details of the failure are as follows:
 0:11.32 
 0:11.32 AttributeError: 'unicode' object has no attribute 'iteritems'
 0:11.32 
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/mach_commands.py", line 1559, in artifact_install
 0:11.32     return artifacts.install_from(source, self.distdir)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 1062, in install_from
 0:11.32     return self.install_from_recent(distdir)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 1024, in install_from_recent
 0:11.32     return self._install_from_hg_pushheads(hg_pushheads, distdir)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 1010, in _install_from_hg_pushheads
 0:11.32     urls = self.find_pushhead_artifacts(task_cache, self._job, tree, hg_hash)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 925, in find_pushhead_artifacts
 0:11.32     urls = task_cache.artifact_urls(tree, job, pushhead, self._download_symbols)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 486, in wrapper
 0:11.32     result = method(self, *args, **kwargs)
 0:11.32   File "/Users/gkruitbosch/dev/mozilla-aurora/python/mozbuild/mozbuild/artifacts.py", line 661, in artifact_urls
 0:11.32     url = self._queue.buildUrl('getLatestArtifact', taskId, artifact_name)
 0:11.32   File "/usr/local/lib/python2.7/site-packages/taskcluster/baseclient.py", line 177, in buildUrl
 0:11.32     for key, value in six.iteritems(replDict):
 0:11.32   File "/usr/local/lib/python2.7/site-packages/six.py", line 599, in iteritems
 0:11.32     return d.iteritems(**kw)
 0:11.35 make[4]: *** [recurse_artifact] Error 1
 0:11.35 make[3]: *** [artifact] Error 2
 0:11.35 make[2]: *** [default] Error 2
 0:11.35 make[1]: *** [realbuild] Error 2
 0:11.35 make: *** [build] Error 2
 0:11.38 0 compiler warnings present.
See Also: → bug 1297585, bug 1306614
This looks like bug 1306614.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306614
You need to log in before you can comment on or make changes to this bug.