unable to double-click to select word

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Composer
--
critical
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Kathleen Brade, Assigned: Charles Manske)

Tracking

({regression})

Trunk
mozilla1.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

16 years ago
I am unable to double-click to select a word.
I expect the word to select but nothing happens.
This is a regression.
(Reporter)

Updated

16 years ago
Keywords: regression
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: unable to double-click to select word. → unable to double-click to select word
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Whiteboard: nsbeta1
(Assignee)

Comment 1

16 years ago
Created attachment 74760 [details] [diff] [review]
Fix

We must not stop event bubbling all the time for double click,
only when we have selected an element.
Fall through to do word-selection when clicking on text.
(Assignee)

Updated

16 years ago
Keywords: nsbeta1, patch, review
Whiteboard: nsbeta1 → FIX IN HAND, need r=,sr=

Comment 2

16 years ago
Comment on attachment 74760 [details] [diff] [review]
Fix

r = jfrancis
Attachment #74760 - Flags: review+
(Assignee)

Comment 3

16 years ago
Created attachment 74783 [details] [diff] [review]
Updated fix

Cleaned up logic after discussing with reviewers.
This avoids doing both selection->Collapse()
and selecting the element. 
Simlifies when to call preventDefault.
(Assignee)

Updated

16 years ago
Attachment #74760 - Attachment is obsolete: true
(Assignee)

Comment 4

16 years ago
Created attachment 74786 [details] [diff] [review]
Update fix #2

Same as previous, but changed "if ( !(buttonNumber == 0 && clickCount == 2)"
to "if (isContextClick)" since this is all within the block:
if (isContextClick || (buttonNumber == 0 && clickCount == 2))
Attachment #74783 - Attachment is obsolete: true

Comment 5

16 years ago
cc: tucson/smoketester
(Reporter)

Comment 6

16 years ago
Comment on attachment 74786 [details] [diff] [review]
Update fix #2

r=brade
Attachment #74786 - Flags: review+

Comment 7

16 years ago
*** Bug 132128 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Comment on attachment 74786 [details] [diff] [review]
Update fix #2

looks like you're missing some or-bars after the node-type tests for "th" and
"tr"

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=,sr= → FIX IN HAND, need sr=
(Assignee)

Comment 9

16 years ago
Created attachment 75186 [details] [diff] [review]
Update #3

Fixed missing "||" found by scc
Attachment #74786 - Attachment is obsolete: true

Comment 10

16 years ago
Comment on attachment 75186 [details] [diff] [review]
Update #3

sr=scc
Attachment #75186 - Flags: superreview+
(Reporter)

Comment 11

16 years ago
Comment on attachment 75186 [details] [diff] [review]
Update #3

r=brade
Attachment #75186 - Flags: review+

Comment 12

16 years ago
Comment on attachment 75186 [details] [diff] [review]
Update #3

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #75186 - Flags: approval+
(Assignee)

Comment 13

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, need sr=

Comment 14

16 years ago
verified in 3/21 build.

working now...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.