Open Bug 1317429 Opened 4 years ago Updated 3 years ago

Can't copy image from web content and paste into macOS

Categories

(Core :: DOM: Serializers, defect, P3)

49 Branch
x86_64
macOS
defect

Tracking

()

UNCONFIRMED

People

(Reporter: laurens, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

FF 49.0.2 on OS X, also tried in Safe mode.

1. Goto https://www.mozilla.org/en-US/firefox/new/
2. Select FF logo in top left and Copy Image
3. Open, say, TextEdit and paste




Actual results:

No image appears


Expected results:

The Firefox logo should be pasted in the document
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Component: Untriaged → Serializers
Product: Firefox → Core
Michael, can you take a look?

I'm assuming this isn't a regression but if it is it should be higher than P3.
Flags: needinfo?(michael)
Priority: -- → P3
I asked jeff to download ESR and try the reproduction steps and the image pasting seemed to not work. This makes me think that it's not a regression.
Flags: needinfo?(michael)
QA, can you please determine if image copy/paste ever worked on OS X? Bug 1146715 at least indicates copying an animated GIF didn't work with 39 on OS X.

Thanks!
Keywords: qawanted
I tried to find the regression with mozregression, but unfortunately the versions are too old and I couldn't find the exact build where this bug came from. I finally managed to narrow it down to this result. 
Firefox Regression Range Link Maker (http://bsmedberg.github.io/firefox-regression-range-finder/ -works only on Firefox-) doesn't work either. I'm guessing because of the same reason. 

Last good build: Nightly - 12.0a1 2012-01-04
First bad build: Nightly - 12.0a1 2012-01-05
I manually generated a pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=200a8d1fb452&tochange=10894668e37f


I tested on releases first, then I started to test on Nighlty using Mac OS x 10.10.5.
In conclusion, I would say that this is a regression, because at some point you could do this in Firefox.
Flags: needinfo?(overholt)
Thank you, Oana! So it's a regression from a long time ago. We'll track this as something to fix.
Flags: needinfo?(overholt)
Keywords: qawanted
No longer blocks: 1390899
Summary: Copy Image not working in OS X → Can't copy image from web content and paste into macOS
You need to log in before you can comment on or make changes to this bug.