Closed Bug 1317447 Opened 3 years ago Closed 3 years ago

parentMessageManager is null error

Categories

(WebExtensions :: General, defect)

defect
Not set

Tracking

(firefox52 verified, firefox53 verified)

VERIFIED FIXED
mozilla53
Tracking Status
firefox52 --- verified
firefox53 --- verified

People

(Reporter: andy+bugzilla, Assigned: kmag)

References

Details

Attachments

(1 file)

1. Grab nightly
2. go to about:config and set webextensions.storage.sync.enabled to true
3. install an add-on that uses chrome.storage.sync, in my case I
3.a made a copy of favourite-colour from mdn examples and replace storage.local with storage.sync
3.b turned off xpinstall.signatures.required
4. went to about:addons > Favourite Color, changed the colour
5. waited a few seconds and got the following error:

Full message: TypeError: context.parentMessageManager is null
Full stack: call/<@resource://gre/modules/ExtensionParent.jsm:468:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:932:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:11
this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:776:7
this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:711:7
waitForSyncCallback@resource://services-common/async.js:98:7
makeSpinningCallback/callback.wait@resource://services-common/async.js:152:27
create@resource://gre/modules/services-sync/engines/addons.js:315:19
Store.prototype.applyIncoming@resource://services-sync/engines.js:352:7
applyIncoming@resource://gre/modules/services-sync/engines/addons.js:297:5
Store.prototype.applyIncomingBatch@resource://services-sync/engines.js:316:9
doApplyBatch@resource://services-sync/engines.js:1025:32
SyncEngine.prototype._processIncoming/newitems.recordHandler@resource://services-sync/engines.js:1154:9
getBatched@resource://services-sync/record.js:771:9
SyncEngine.prototype._processIncoming@resource://services-sync/engines.js:1161:18
SyncEngine.prototype._sync@resource://services-sync/engines.js:1630:7
WrappedNotify@resource://services-sync/util.js:166:21
Engine.prototype.sync@resource://services-sync/engines.js:689:5
_syncEngine@resource://services-sync/stages/enginesync.js:321:7
sync@resource://services-sync/stages/enginesync.js:168:15
onNotify@resource://gre/modules/services-sync/service.js:1328:7
WrappedNotify@resource://services-sync/util.js:166:21
WrappedLock@resource://services-sync/util.js:121:16
_lockedSync@resource://gre/modules/services-sync/service.js:1318:12
sync/<@resource://gre/modules/services-sync/service.js:1310:14
WrappedCatch@resource://services-sync/util.js:95:16
sync@resource://gre/modules/services-sync/service.js:1298:5

At this time it looks like the data didn't make it to the server, but the only reason I think that is it hasn't appeared on my other Firefox instance yet.
Assignee: nobody → eglassercamp
The error doesn't have anything to do with sync. It happens when we're trying to send the response to the options page, and probably means that the tab has already been closed.
Summary: Error on syncing → parentMessageManager is null error
1479158519166	Sync.SyncScheduler	DEBUG	Global Score threshold hit, triggering sync.
1479158519166	Sync.Service	DEBUG	User-Agent: Firefox/53.0a1 (Intel Mac OS X 10.10) FxSync/1.55.0.20161114043454.desktop
1479158519167	Sync.Service	INFO	Starting sync at 2016-11-14 13:21:59
1479158519167	Sync.Service	DEBUG	Exception calling anonymous function: Could not acquire lock. Label: "service.js: sync".
1479158519167	Sync.Service	INFO	Cannot start sync: already syncing?
Assignee: eglassercamp → kmaglione+bmo
Comment on attachment 8812328 [details]
Bug 1317447: Provide better error messages when browser is removed before we can send replies.

https://reviewboard.mozilla.org/r/94120/#review94318
Attachment #8812328 - Flags: review?(aswan) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8dc1806bb827ab612513ea27918b361ae584d99
Bug 1317447: Provide better error messages when browser is removed before we can send replies. r=aswan
Comment on attachment 8812328 [details]
Bug 1317447: Provide better error messages when browser is removed before we can send replies.

Approval Request Comment
[Feature/regressing bug #]: Bug 1316396
[User impact if declined]: This bug improves the reporting of harmless errors, which tend to confuse developers about the cause of actual issues that they run into.
[Describe test coverage new/current, TreeHerder]: There is no coverage for the error reporting in particular, but the code that the changes affect is covered by significant portions of our test suite.
[Risks and why]: Low. This change only affects the reporting of errors, and should have no other practical effect at runtime.
[String/UUID change made/needed]: None.
Attachment #8812328 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d8dc1806bb82
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8812328 [details]
Bug 1317447: Provide better error messages when browser is removed before we can send replies.

improve some error messages for developers, take in aurora52
Attachment #8812328 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I was able to reproduce this issue on Firefox 53.0a1 (2016-11-14) under Windows 10 64-bit.
Verified fixed on Firefox 53.0a1 (2016-11-28) and Firefox 52.0a2 (2016-11-28) under Windows 10 64-bit and Ubuntu 16.04 32-bit.
“Cannot send function call result: other side closed connection  ExtensionParent.jsm:469” error is successfully thrown in Browser Console.
Status: RESOLVED → VERIFIED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.