Drag'n'drop of a link gives zero data-flavors




Drag and Drop
16 years ago
9 years ago


(Reporter: Paul Libbrecht, Unassigned)



Firefox Tracking Flags

(Not tracked)





16 years ago
In Linux using KDE2 (attempted on SuSE linux 7.2), the drag-n-drop of a link from Mozilla into a Java application (running JDK 1.4.0, 1.3.1, or 1.3.0 from Sun) the DataFlavors presented to the DropTarget are empty.

Don't know wether this should be a Sun's bug or a Mozilla bug. But I'd really have this fixed.
Over to D&D
Assignee: asa → blaker
Component: Browser-General → XP Apps: Drag and Drop
QA Contact: doronr → tpreston

Comment 2

16 years ago
More tests show: IBM Virtual machine does the same (version 1.3).
Moreover this doesn't seem to be KDE dependent,ie. the same happens with Gnome.
And it's no better in applets either.
In all the browsers on Linux that seem to make a usable drag'n'drop for java
application is only: Galleon (Gnome's HTML viewer) and Netscape 4 (which is,
however, unusable for applets: it's mechanism uses a file in /tmp/).

I have set up a little applet that can be well used to test.
(source available one directory lower)
License is MPL although there's nothing written there.
Paul Libbrecht: can you still reproduce this with a recent Mozilla version (like
1.0RC3)? If not, mark this bug "worksforme"
no answer
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
Sorry for having missed the previous request to reproduce.
Yes, it is still valid, sadly (tests were on Mozilla 1.1b and KDE 2 with java VM
Sun's 1.3 and Sun's 1.4.1b1).
Actually, I reported a bug at Sun and they claimed it was fixed on 1.4.1b1 but I
could not have the same fact.
Am I the only one experiencing this ?
It's a really bad one, I believe, at least for someone like me developing a
java-based authoring tool for ocntent displayed in a web-application.
Resolution: WORKSFORME → ---

Comment 6

16 years ago
I have just updated the drop-it-tester so that it says there's zero data-flavours.
(this also occurs in applet frames) and have checked again, it works on MacOSX
(all Mozilla versions) and Windows 2000 (Netscape 6.2).

Comment 7

16 years ago
I am experiencing this phenomenon too.

Mozilla 1.1
SunOS 5.8/CDE 1.4
JDK 1.2.2, 1.3.1, 1.4.0 and 1.4.1-RC

So we still don't know for certain if the bug is Mozilla or Java, but it's
cross-Unix and cross-GUI

Comment 8

16 years ago
Related to bug 40608?

Comment 9

16 years ago
Not really related - that one is complaining that something was getting a drop
with an invalid flavour. This bug is complaining that the drop event has zero
flavours - even an invalid one is potentially useful.

As I typed the above, I guess it could be that Java doesn't know what to do with
an invalid flavour, so it ignores it, and all that's left is an empty list :-(

Comment 10

16 years ago
I am afraid I did not mention that actually drag'n'drop of a link to a KDE XTerm
is also broken: only the first letter of the URL is dropped (i.e. "h" or "f"

Comment 11

16 years ago
Can we have a clearer description of a test environment? Is there an applet that
could be used to simulate the D&D environment?

Comment 12

16 years ago
Why is the link provided not decent enough ?

I've just written a little explanatory text...
Basically... try dropping a link within the window that pops-up.
(dropping a link on an applet implementing drop-target is currently still
interpreted by most browsers as being an "open-this-link in this
browser-window", that may be changed in the future but is much less of urgency.

Comment 13

16 years ago
Woups, woups.
I'm really sorry, my latest enrichement created a bug which turned out not be
shown on Darwin... now it is running and makes the described behaviour using
Mozilla 1.2 (Gecko/20021126).

Hope that will help.


Comment 14

16 years ago
This might be some sort of library bug. The same thing happens dragging from
Nautilus file manager on Solaris8/Gnome 2.0beta2.

It is identified as a problem in Java bug 4746177 at
http://developer.java.sun.com/developer/bugParade/bugs/4746177.html which they
claim will be fixed in some future version of Java.

The Evaluation there gives some understanding of the issues. Perhaps Mozilla can
address it too, as the Mozilla release cycle is much faster than Java's, and it
may affect more things than just Java.

Comment 15

16 years ago
Moreover... I could get the fix that adds a line to the flavormap.properties
file to work:
- Mozilla 1.2 (Linux)
- Java 1.4.1 beta 1
with the fix applied.
It seems the fix does not work with the java 1.3.1 VMs
(also the programmatic fix does only work with java 1.4).

Saying it is fixed is somewhat annoying: in particular, the drop of a link into
a KDE's konsole is still... one character long.

Comment 16

15 years ago
This seems to be fixed in JDK 1.4.2.
At least so are my current experiences with Mozilla 1.4 and JDK 1.4.2 from Sun
on Linux Mandrake 9.0.

Can other platform people confirm ?

Comment 17

15 years ago
Yes it seems to work for me (24 flavours!) with mozilla nightly build 2003072122
 (Solaris 8) and Java 1.4.2, but still gives no flavours with Java 1.4.1, so it
seems it was a Java bug.
Assignee: bross2 → nobody
QA Contact: tpreston
->WFM based on comments 16 and 17.
Last Resolved: 16 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.