IMAP not cleaned on mail close

RESOLVED DUPLICATE of bug 42456

Status

RESOLVED DUPLICATE of bug 42456
17 years ago
10 years ago

People

(Reporter: hannembb, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020317
BuildID:    2002031708

When I choose "Compact Folders" or have the "Expunge on Exit" preference
selected, it will only expunge or compact the mail folder that I am currently
viewing.  This is probably a bug, because "Compact Folders" has an "S" in it,
and it makes more sense to have a clean all function rather than doing it piecemeal.

Reproducible: Always
Steps to Reproduce:
1. have an IMAP mailbox with multiple-folder hierarchy.
2. delete several messages in some folders (I have mine set to "mark file as
deleted".
3. try the "Compact Folders" command, or exit with "Expunge on Exit" checked.

Actual Results:  only those deleted emails actually present in the "Inbox" are
removed.  Other folders within the Inbox hierarchy are left as-is.

Expected Results:  All "marked as deleted" messages should be expunged.

Updated

16 years ago
QA Contact: huang → gchan

Comment 1

16 years ago
Reporter: Can you still confirm that this bug exists. The build you were using
at the time was old even then.

Comment 2

16 years ago
duplicate of 131747

*** This bug has been marked as a duplicate of 42456 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.