Closed Bug 1317485 Opened 5 years ago Closed 5 years ago

Can't evaluate scripts in console if loading debugger frontend on a page that has no sources

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox52 affected)

RESOLVED DUPLICATE of bug 1317819
Tracking Status
firefox52 --- affected

People

(Reporter: bgrins, Unassigned)

References

Details

Attachments

(1 file)

STR:

Open a page with no JS: `data:text/html,`.  Or one that has a non-parseable script tag: https://bug1313921.bmoattachments.org/attachment.cgi?id=8805840.
Open debugger
Open console
Evaluate anything in the console

Expected:
Evaluation happens

Actual:
No response.  Error from debugger forntend: TypeError: frames is null panel.js:53:9.

Filing under debugger because if I don't open the debugger UI the evaluation happens successfully.
James, looks like we might need an extra null check here: https://dxr.mozilla.org/mozilla-central/source/devtools/client/debugger/new/panel.js#53.  Is it expected that this._selectors().getFrames will return null in certain cases?
Flags: needinfo?(jlong)
See Also: → 1313921
Priority: -- → P3
I just checked and I think this is also breaking input in the Browser Content Toolbox entirely.

Developer -> Browser Content Toolbox
Open console and run some script

Get the same 'TypeError: frames is null' error
I was going to review this today but then Jason mentioned that Julian also filed this bug: bug 1317819

Brian, you can only make changes to the tests on github: https://github.com/devtools-html/debugger.html/tree/master/src/test/mochitest. When we deploy the debugger, we copy over those tests as well. Since you have changes to the test, are you OK if we go with Julian's patch?

What do the changes to the tests do? If you don't mind, can you make a PR instead?
Flags: needinfo?(jlong)
OK, looks that that's already landed so going to dupe this to that bug

(In reply to James Long (:jlongster) from comment #5)
> I was going to review this today but then Jason mentioned that Julian also
> filed this bug: bug 1317819
> 
> Brian, you can only make changes to the tests on github:
> https://github.com/devtools-html/debugger.html/tree/master/src/test/
> mochitest. When we deploy the debugger, we copy over those tests as well.
> Since you have changes to the test, are you OK if we go with Julian's patch?
> 
> What do the changes to the tests do? If you don't mind, can you make a PR
> instead?

It's just a regression test that hits this particular case.  I'll copy it over
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317819
Attachment #8810943 - Flags: review?(jlong)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.