checksums broken in Firefox 51.0b1

RESOLVED DUPLICATE of bug 1317593

Status

Release Engineering
Release Automation
RESOLVED DUPLICATE of bug 1317593
a year ago
a year ago

People

(Reporter: nthomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
19:23:24     INFO - Run as scripts/scripts/release/generate-checksums.py --stage-product firefox --bucket-name-full net-mozaws-prod-delivery-firefox --credentials /builds/release-s3.credentials --tools-repo /tools/checkouts/build-tools
....
19:24:56     INFO - Running main action method: sign
19:24:56     INFO - retry: Calling _get_revision with args: (<mozharness.base.vcs.mercurial.MercurialVCS object at 0x24adb10>, '/builds/slave/rel-m-beta-fx_chcksms-00000000/build/tools'), kwargs: {}, attempt #1
19:24:56     INFO - rmtree: /builds/slave/rel-m-beta-fx_chcksms-00000000/build/tools
19:24:56     INFO - retry: attempt #1 caught exception: vcs share base not defined; refusing to operate sub-optimally
19:24:56     INFO - retry: Failed, sleeping 60 seconds before retrying

From https://dxr.mozilla.org/mozilla-beta/source/testing/mozharness/mozharness/base/vcs/mercurial.py#362. We should switch away from using /tools/checkouts and use the share instead.
(Reporter)

Comment 1

a year ago
Full log - https://mozilla-release-logs.s3.amazonaws.com/mozilla-beta/firefox-51.0b1/build1/firefox_mozilla-beta_checksums_builder-all-er2SVtaXSGKHKir-85KxQg-0
Filed later than this one, but have a patch.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317593
Blocks: 1318052
You need to log in before you can comment on or make changes to this bug.