Mercurial.vcs_checkout() should use HG_SHARED_DIR when vcs_share_base is not defined

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: rail, Assigned: rail)

Tracking

unspecified

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
https://tools.taskcluster.net/task-inspector/#er2SVtaXSGKHKir-85KxQg/0 failed to clone the tools repo which is defined in https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/scripts/release/generate-checksums.py#230 because it doesn't pass the check defined in https://dxr.mozilla.org/mozilla-beta/source/testing/mozharness/mozharness/base/vcs/mercurial.py#362

19:36:56    FATAL - Automation Error: Can't checkout /tools/checkouts/build-tools!
19:36:56    FATAL - Caught exception: vcs share base not defined; refusing to operate sub-optimally

When Mercurial.vcs_checkout() is called, sometimes it may set vcs_share_base to None in https://dxr.mozilla.org/mozilla-central/source/testing/mozharness/mozharness/base/vcs/vcsbase.py#70-71.

Later when https://dxr.mozilla.org/mozilla-beta/source/testing/mozharness/mozharness/base/vcs/mercurial.py#356 is executed, it finds that value set to None and doesn't use HG_SHARED_DIR.
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1317582
(Assignee)

Comment 3

2 years ago
This is blocking 51.0b1
Severity: normal → critical

Comment 4

2 years ago
mozreview-review
Comment on attachment 8810719 [details]
Bug 1317593 - Fix logic in settings vcs_share_base

https://reviewboard.mozilla.org/r/93026/#review93204
Attachment #8810719 - Flags: review?(gps) → review+

Comment 5

2 years ago
Pushed by raliiev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c8359a83645
Fix logic in settings vcs_share_base r=gps

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0c8359a83645
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.