Account Avatar Icon in Sync settings page reset to default when debug mode toggled

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: maliu, Assigned: seanmaltby, Mentored)

Tracking

unspecified
Firefox 54
All
Android
Points:
---

Firefox Tracking Flags

(firefox54 verified)

Details

(Whiteboard: [lang=java][good first bug])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
 * Enter Account sync settings, toggle to enable debug mode.

Expected Behaviour:
 * Account avatar icon stay still, not to be reset to default.

Comment 1

2 years ago
i want to try this
(Reporter)

Comment 2

2 years ago
(In reply to Ajinkya from comment #1)
> i want to try this

Sure! Have you setup a build environment yet?
Flags: needinfo?(ajinkyaambre9394)

Comment 3

2 years ago
Hi Max, 
I tried to reproduce the issue with following steps, 

1. created firefox android (version 50.0.1) sync account on my device
2. set the account picture
3. then enabled debug mode via firefox settings -> advanced -> Developer Tools -> Remote Debugging via USB, then toggled it.
4. went back to sync settings page

as per the issue, now account picture should have been reset to default avatar, but that didn't happened and I can see the originally set account picture been displayed as usual.


I believe the above steps are right, if not then please correct it else what am I missing or issue might be not reproducible?
Flags: needinfo?(max)
(Reporter)

Comment 4

2 years ago
Hi Ankur,

Sorry maybe bug description not clear enough. The debug mode be inside the account syncing debug purpose. So it only exist in Nightly version. Your step 3 should be replaced to "Settings -> account -> menu -> toggle debug mode"
Flags: needinfo?(max)

Comment 5

2 years ago
(In reply to Max Liu [:maliu] from comment #2)
> (In reply to Ajinkya from comment #1)
> > i want to try this
> 
> Sure! Have you setup a build environment yet?

yes i did.

Comment 6

2 years ago
The bug is still active but know the procedure to replicate it is:
Settings->Acount(E-mail/Username)->More->enable Debug-mode

Comment 7

2 years ago
Can you point me out somewhere where i can see documentation about the contents of the mozilla-center/mobile folder? just to find out where should i start looking for the source of this bug
Flags: needinfo?(s.kaspari)
Mentor: s.kaspari
Flags: needinfo?(s.kaspari) → needinfo?(max)
(Reporter)

Comment 8

2 years ago
Hi Francisco,

Since it's a Android Preference, you can start from [1] PreferenceFragment. After that, you may find out that account page is implemented by [2] FxAccountStatusFragment. Checkout which member field stores the data row with icon and account name?

[1] https://dxr.mozilla.org/mozilla-central/rev/96cb95af530477edb66ae48d98c18533476e57bb/mobile/android/services/src/main/java/org/mozilla/gecko/background/preferences/PreferenceFragment.java

[2] https://dxr.mozilla.org/mozilla-central/rev/96cb95af530477edb66ae48d98c18533476e57bb/mobile/android/services/src/main/java/org/mozilla/gecko/fxa/activities/FxAccountStatusFragment.java
Flags: needinfo?(max)
Comment hidden (mozreview-request)
(Assignee)

Comment 10

2 years ago
Not sure if I submitted that correctly, but I believe I fixed the issue in the above commit.
(Reporter)

Comment 11

2 years ago
mozreview-review
Comment on attachment 8829178 [details]
Bug 1317643 - Resolved issue where the avatar icon resets to default.

https://reviewboard.mozilla.org/r/106340/#review107728

LGTM
Attachment #8829178 - Flags: review?(max) → review+
(Reporter)

Updated

2 years ago
Flags: needinfo?(ajinkyaambre9394)
(Reporter)

Updated

2 years ago
Assignee: nobody → seanmaltby
Keywords: checkin-needed

Comment 12

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a29f11fae377
Resolved issue where the avatar icon resets to default. r=maliu
Keywords: checkin-needed

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a29f11fae377
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Hello I've verified this issue using a Samsung Galaxy Note 4 (Android 5.0.1), seems to be working fine as the account picture is not reset.
status-firefox54: fixed → verified
You need to log in before you can comment on or make changes to this bug.