multi-column layout in RTL: first column smaller than the rest

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: David D Lowe, Unassigned)

Tracking

({testcase})

49 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

I created a multi-column layout using `-moz-column-count: 3` in a RTL HTML document, with 11 items.

Because this is a RTL column, when I refer to the "first column", I mean the column that is the furthest to the right.

I have attached a demo.html and screenshots. I experience this bug on Firefox 49.0.2 on macOS, and on Firefox Developer Edition 51.0a2 (2016-11-14) (64-bit) on macOS. I've also attached a screenshot of the same page in Chrome, which behaves as expected.


Actual results:

The first column had three items, the second column had four items, and the third column had four items.


Expected results:

I expected the first column to have four items, the second column to have four items, and the third column to have three items.
(Reporter)

Comment 1

a year ago
Created attachment 8810800 [details]
demo.html a small reproducible test-case
(Reporter)

Comment 2

a year ago
Created attachment 8810801 [details]
This is a screenshot of the unexpected buggy behaviour of demo.html
(Reporter)

Comment 3

a year ago
Created attachment 8810802 [details]
This is a screenshot of the expected behaviour of the demo.html in Chrome
(Reporter)

Comment 4

a year ago
Note that this bug only seems to manifest itself at certain browser widths. Try resizing the browser if you don't see the buggy behaviour.
(Reporter)

Comment 5

a year ago
I just noticed that the bullet item decorations are missing from the Chrome screenshot. Obviously, the bug report is not about that :)

Updated

a year ago
Component: Untriaged → Layout
Product: Firefox → Core
I think this is a bug in Chrome actually.

https://drafts.csswg.org/css-break/#break-margins
"When an unforced break occurs between block-level boxes,
any margins adjoining the break truncate to the remaining
fragmentainer extent before the break, and are truncated
to zero after the break."

What you see in Firefox is the "truncated to zero after
the break" bit.

You can file a bug on Chrome here:
https://bugs.chromium.org/p/chromium/issues

(Also, you can simplify the test by removing the dir=rtl
because the behavior is the same in LTR.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Keywords: testcase
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.