autosubscribe does not work with news://servername

VERIFIED DUPLICATE of bug 68302

Status

SeaMonkey
MailNews: Account Configuration
VERIFIED DUPLICATE of bug 68302
17 years ago
14 years ago

People

(Reporter: TT, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I cannot use the news:// URL to subscribe to a new news server.  All sorts of
bizarre things happen.  If I type in news://news.ecomstation.nl, it asks me if I
want to subscribe to the "news.ecomstation.nl" newsgroup, not realizing that
news.ecomstation.nl is a server.  Sometimes it asks me if I want to subsribe to
"s.ecomstation.nl" or some other screwed up variation.

I think the ability to click on a news:// URL and read the newsgroup, even if
it's not one you've subscribed to, is very important.  A confirmation dialog
asking you if you want to subscribe to that news server is okay.  To keep the UI
simple, Mozilla should just fill in the Acount information based on the default
news server, if it exists.

Comment 1

17 years ago
I don't know what the correct behavior is supposed to be, but i see the same
behavior on Linux. Change platform to "all"?
(Reporter)

Comment 2

16 years ago
This is what I think it should do: when you click on a news URL like
news://news.ecomstation.nl/ecomstation.support.install, it should do the following:

1. Ask you if you want to add news.ecomstation.nl to your list of news servers.
 If you say yes, it will create a new news account pointing to
news.ecomstation.nl.  It will fill in some defaults for you, like your name and
email address, or maybe it will ask you.

2. Once that's done, it will ask you if you want to subscribe to the newsgroup
ecomstation.support.install.  If you say yes, then it will add that newsgroup to
your news.ecomstation.nl account, and then open it and show all the messages.

Currently, Mozilla does most of this.  However, when it tries to add the
news.ecomstation.nl account, besides asking you for your name and email address
(which it should pre-fill from the default),  it then asks you for the news
server!  It already knows what the server is.

After all this, it asks you if you want to subscribe to
ecomstation.support.install, giving you two choices: Ok or Cancel.  But it
doesn't matter what you select, because you'll be subsribed to
ecomstation.support.install anyway!

So basically, there are three bugs:

1. Mozilla doesn't pre-fill the name/email with the defaults when creating a new
news account from an autosubscribe

2. Mozilla doesn't remember what the news server was, and so it asks you,
forcing you to type in what you just clicked on.

3. At the end, Mozilla subscribes you to the newsgroup even after you tell it
you've changed your mind.
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
QA Contact: nbaca → stephend

*** This bug has been marked as a duplicate of 68302 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.