Closed Bug 13179 Opened 21 years ago Closed 10 years ago

Smart window sizing, working zoom

Categories

(Core :: XUL, defect, trivial)

PowerPC
macOS
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 232919

People

(Reporter: sdagley, Unassigned)

References

Details

(Keywords: helpwanted, platform-parity)

Mac specific platform integration issues:

Smart window sizing, working zoom where content is accounted for when deciding
how big to make the window.
Tagging M14 Assigned for now so Bugzilla won't send me nastygrams
Component: other → XPApps
QA Contact: leger → claudius
Summary: [PI] Smart window sizing, working zoom → [PP] Smart window sizing, working zoom
Updating QA contact.
mass moving m14 bugs to m15
Keywords: pp
Summary: [PP] Smart window sizing, working zoom → Smart window sizing, working zoom
Moving to M18 to sync with #4252
Target Milestone: M15 → M18
Where will this be used? It seems inappropriate for both Navigator and Messenger; 
and in windows like Bookmarks, Address Book, History etc, it will only be useful 
in the unlikely event that you have few enough items in these windows to fit on 
the screen at once.
nav triage team:

Nice feature to have, but not going to do this for beta1. Marking nsbeta1-,
reassigning to pchen
Assignee: sdagley → pchen
Status: ASSIGNED → NEW
Keywords: nsbeta1-
Milestone 0.8 has been released. We should either resolve this bug or update its
milestone.
Keywords: helpwanted
Target Milestone: M18 → Future
Clearing target:future as that's not going to get it any eyeball time (and pchen 
isn't the one that future'd it)
Target Milestone: Future → ---
>Where will this be used?

On a 21-24" display with resolution set to 1280x1024 or higher. A *lot* of stuff
can fit on the screen at those resolutions. Should this be 4xp, as Communicator
did this quite well (sized windows appropriately to accomodate content when
clicking the resize button)?
Target Milestone: --- → Future
Marking nsbeta1- bugs as future to get off the radar.
See also bug 1187, [RFE] Rightsizing an HTML window.
*** Bug 106414 has been marked as a duplicate of this bug. ***
Setting OS=All as this has implications on all Mac OS versions.

Setting Severity=Trivial as this isn't about functionality loss, but rather
suboptimal functionality...zoom does, in fact, occur, but not well.
Severity: normal → trivial
OS: Mac System 8.5 → All
unsetting All. We use os values to indicate the lowest common demoninator. 
Macintosh:All implies it occurs on say LinuxPPC or NetBSD PPC which is not what
we're trying to say.
OS: All → Mac System 8.5
-> default assignee
Assignee: pchen → trudelle
QA Contact: claudius → sairuh
Target Milestone: Future → ---
->future
Target Milestone: --- → Future
This is nontrivial. Most pages fit within the width of the screen (generally
1024 or 1280 for me), and zooming them to (mostly) fill the screen means they
can't be staggered usefully. With rightsizing, I can often fit many windows
onscreen with a visible region of each to click, but with Mozilla 1.0.0RC1 on
Mac OS X, they're all the same size and location, and I must use the menu (or
nonstandard keyboard shortcuts) to switch among them. This is more important on
Mac OS X than Linux, since the Command-` window cycling shortcut is also missing.
I'd like to see this behavior in Mozilla and Chimera. It's one of my favorite
Communicator features (i.e., behave as the Finder does, zoom to remove
scrollbars where possible).
Mass moving all of my open Nav/toolkit bugs to new owner.
Assignee: trudelle → sgehani
Updating OS since support for mac classic is dead.
OS: Mac System 8.5 → MacOS X
Product: Core → Mozilla Application Suite
Moving this to core since this seems to deal with the native zoom buttons... (the new zoom feature zooms all of the page content, but in here it seems that it's not enough with that). Not sure if this is doable or valid.
Assignee: samir_bugzilla → nobody
Component: UI Design → XP Toolkit/Widgets: XUL
Priority: P3 → --
Product: SeaMonkey → Core
QA Contact: bugzilla → xptoolkit.xul
Target Milestone: Future → ---
This is an older bug, but it's the same issue and bug 232919 has much more useful discussion.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 232919
Moving to Core:XUL per https://bugzilla.mozilla.org/show_bug.cgi?id=1455336
Component: XP Toolkit/Widgets: XUL → XUL
You need to log in before you can comment on or make changes to this bug.