Firefox 50 release crashes when typing with third party IME

RESOLVED DUPLICATE of bug 1300143

Status

()

Core
Widget: Win32
--
critical
RESOLVED DUPLICATE of bug 1300143
8 months ago
7 months ago

People

(Reporter: G, Unassigned)

Tracking

({crash, inputmethod})

50 Branch
x86
Windows XP
crash, inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Steps to reproduce:

Launch Firefox (safe mode or not);
Open a search engine;
Switch to a third party IME(in my case, Smart ABC, an IME for simplified Chinese);
Just type a letter on the page, Firefox will crash.

Additional details:
I am running Firefox 32bit Windows


Actual results:

Firefox crashes and quits completely


Expected results:

Third party IME shouldn't crash Firefox
(Reporter)

Updated

8 months ago
OS: Unspecified → Windows
Hardware: Unspecified → x86

Comment 1

8 months ago
What is report id by this crash?  See https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help#w_get-help-fixing-this-crash
Flags: needinfo?(geraldx)

Updated

8 months ago
Keywords: inputmethod
(Reporter)

Comment 2

8 months ago
Hello,

report id is the following:
cb2e68a0-87ca-4da5-b4e6-95c4517103e6

I just did another test on Windows 7 64 bit with another third party IME (Sougou IME), it works fine.

However I am still seeing crashes on XP 32bit with Smart ABC.
Flags: needinfo?(geraldx)

Comment 3

8 months ago
bp-cb2e68a0-87ca-4da5-b4e6-95c4517103e6 is invalud.  Could you send crash data via crash reporter?

Comment 4

8 months ago
(maybe, this is already fixed by 51... :-<)

Updated

8 months ago
Component: Untriaged → Widget: Win32
OS: Windows → Windows XP
Product: Firefox → Core
(Reporter)

Comment 5

8 months ago
Oops, sorry my bad, crash-reports.mozilla.com was blocked.

Now the crash report should be sent as I can see the above host name is correctly resolved.
(Reporter)

Comment 6

8 months ago
https://crash-stats.mozilla.com/report/index/da6cdfbd-cce8-497a-9381-2f39e2161116
Please use this ID to see the detailed crash log.

Comment 7

8 months ago
The crash report links to bug 1304601 with limited access (for security reasons, I guess).

Makoto, is this bug a dupe of bug 1304601?
Flags: needinfo?(m_kato)

Updated

8 months ago
Severity: normal → critical
Keywords: crash

Updated

8 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(m_kato)
Resolution: --- → DUPLICATE
Duplicate of bug: 1300143

Comment 9

8 months ago
G, Thanks for report.  We consider that this is fixed by 50.x, not 51.

Comment 10

8 months ago
FYI:
I experienced the same crash with 50. 51.0b1 seems to work fine. (I've not tried 50.x.)
You need to log in before you can comment on or make changes to this bug.