Upgrade Firefox 53 to NSS 3.29

RESOLVED FIXED in Firefox 53

Status

()

defect
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: franziskus, Assigned: franziskus)

Tracking

53 Branch
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53+ fixed)

Details

(Whiteboard: [psm-assigned])

Attachments

(1 attachment, 1 obsolete attachment)

Tracking NSS 3.29 for Firefox 53.
Target Milestone: --- → mozilla53

Comment 2

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f296d0342384
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
forgot to set leave-open. there will be more landings
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Priority: -- → P1
Whiteboard: [psm-assigned]
backed out for causing timeouts in dt tests like https://treeherder.mozilla.org/logviewer.html#?job_id=70274867&repo=mozilla-inbound

however the real issue might be the error message in the attachment, this might be explain why a nss change breaks devtools tests
Flags: needinfo?(franziskuskiefer)
[task 2017-01-19T08:54:09.131407Z] 08:54:09     INFO -  "handling good.include-subdomains.pinning.example.com"
[task 2017-01-19T08:54:09.131705Z] 08:54:09  WARNING -  TEST-UNEXPECTED-FAIL | security/manager/ssl/tests/unit/test_cert_chains.js |  - Actual and expected connection result should match - 2153394174 == 0
[task 2017-01-19T08:54:09.131988Z] 08:54:09     INFO -  /storage/sdcard/tests/xpc/security/manager/ssl/tests/unit/head_psm.js:add_connection_test/</<:454

2153394174 is SSL_ERROR_NO_CYPHER_OVERLAP - could it be that the cipher suites that are enabled by default in NSS no longer overlap with what Firefox enables?

Comment 24

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2164277367cc
land NSS ea43fcc316e1, r=me
https://hg.mozilla.org/integration/autoland/rev/3112cbcca0f4
Backed out changeset 2164277367cc for causing timeouts in devtools tests on a CLOSED TREE
Depends on: 1323104
Flags: needinfo?(franziskuskiefer)
Depends on: 1333247
Attachment #8828251 - Attachment is obsolete: true
No longer depends on: 1333247
Posted patch 329ff53.patchSplinter Review
Final NSS 3.29 release for Firefox 53 that currently holds the latest 3.29 beta.
Flags: needinfo?(lhenry)
Attachment #8833910 - Flags: review+
Attachment #8833910 - Flags: approval-mozilla-aurora?
Comment on attachment 8833910 [details] [diff] [review]
329ff53.patch

Let's get the final/release version of NSS 3.29 to replace the beta version, onto aurora.
Flags: needinfo?(lhenry)
Attachment #8833910 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tweaking the flag so this will show in queries. 
Franziskus, do you want to land this on aurora yourself or would you like someone else to do it?
Flags: needinfo?(franziskuskiefer)
https://hg.mozilla.org/releases/mozilla-aurora/rev/9ad41a8fca06
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Flags: needinfo?(franziskuskiefer)
Keywords: leave-open
Resolution: --- → FIXED

Updated

2 years ago
Depends on: 1385790
You need to log in before you can comment on or make changes to this bug.