All users were logged out of Bugzilla on October 13th, 2018

Unity WebGL rendering and mouse/key responsive are delayed, for about 10-15 seconds from the start of the game

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({perf, regression})

52 Branch
x86
Windows 10
perf, regression
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 ?, firefox53 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: performance regression of Unity WebGL


+++ This bug was initially created as a clone of Bug #1317960 +++

Probably, It will be remarkable on low spec PC.

Steps to reproduce:
0. Start Firefox
1. open URL http://beta.unity3d.com/jonas/AngryBots/ 
2. Repeatedly key press Arrow key to move a player
   Repeatedly Move mouse pointer and Press left mouse button

Actual Results:
For about 10-15 seconds from the start of the game, the rendering is delayed and lagged.
After for a while(15sec+), the rendering becomes normal without delay.

Expected Results:
The problem should be less than for 1-2 seconds.(but it depend on CPU/GPU spec)

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d0f06f2fdba053344e07fbd5b4e55af117077dd4&tochange=ad7523af20b9386d4770e7d124ba42ba8b061a70

Regressed by: Bug 1313180
Flags: needinfo?(luke)
(Reporter)

Updated

2 years ago
No longer depends on: 1317960
See Also: → bug 1317967, bug 1317960
(Reporter)

Comment 1

2 years ago
Created attachment 8811272 [details]
about_suppot

Comment 2

2 years ago
Bug 1313180 was the one that accidentally disabled asm.js optimizations and was later fixed by bug 1317967.  I tested on the latest nightly and there is no problem loading.  Are you able to reproduce on the latest nightly?
Flags: needinfo?(luke)
(Reporter)

Comment 3

2 years ago
(In reply to Luke Wagner [:luke] from comment #2)
> Bug 1313180 was the one that accidentally disabled asm.js optimizations and
> was later fixed by bug 1317967.  I tested on the latest nightly and there is
> no problem loading.  Are you able to reproduce on the latest nightly?

https://hg.mozilla.org/mozilla-central/rev/79feeed4293336089590320a9f30a813fade8e3c
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 ID:20161116030212

It works as expected about mouse moving.
However, due to Bug 1317967, I cannot test about key pressing.

Comment 4

2 years ago
Sorry, I'm trying to understand: are you saying that the 10-15 seconds lag are gone, but that bug 1317967 still reproduces?  Does that mean this bug could be closed?
(Reporter)

Comment 5

2 years ago
(In reply to Luke Wagner [:luke] from comment #4)
> Sorry, I'm trying to understand: are you saying that the 10-15 seconds lag
> are gone, 

The delay of mouse interaction is almost same as the good build.

> bug 1317967 still reproduces?  

Yes. 

> Does that mean this bug could be closed?

I will verify after bug 1317967 is fixed.
status-firefox50: --- → unaffected
Component: Untriaged → JavaScript Engine: JIT
Product: Firefox → Core
Priority: -- → P1
(Reporter)

Comment 6

2 years ago
I can confirm the problem is fixed on Nightly53.0a1

https://hg.mozilla.org/mozilla-central/rev/28e2a6dde76ab6ad4464a3662df1bd57af04398a
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 ID:20161118030222


(I cannot confirm on Aurora52.0a2 due to bug 1317967).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → ?
status-firefox53: affected → verified
tracking-firefox52: ? → ---
tracking-firefox53: ? → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.