Remove support for settings_local.py

RESOLVED FIXED

Status

Tree Management
Treeherder: Docs & Development
P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: emorley, Assigned: emorley)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
It has been the source of Vagrant-environment confusion multiple times in the past, and in an environment-variable-centric world really isn't the best way to achieve local custom configuration.

Specifically:
* It doesn't show up in `git status` (by design) so people don't even realise they are running custom settings, that cause later breakage (bug 1291038 is just one example)
* It exists on the host, and not in the VM, so persists even after a `vagrant destroy`, thwarting people's attempts to reset back to defaults
* The only real use-case for it is IMO actually an anti-feature, in that it encourages people to squirrel away development environment tips & tricks, rather than landing them on master where everyone could benefit. For one-off local changes people should use either environment variables, or just modify settings.py along with the PR they are working on.

Before we remove supporting for it, we'll need to:
* Consolidate the LOGGING configs (that are in need of sorting out anyway)
* Move LOCAL_APPS to settings.py
(Assignee)

Comment 1

a year ago
> Specifically:

* Since settings_local.py is only copied from settings_local.example.py once (ie: if it doesn't already exist), when we make improvements to the example file in the repo (or breaking changes), Treeherder devs don't pick them up unless they specifically copy them over.
(Assignee)

Updated

a year ago
Depends on: 1318021
(Assignee)

Updated

a year ago
Depends on: 1320451
Created attachment 8814904 [details] [review]
[treeherder] mozilla:rm-settings_local > mozilla:master
(Assignee)

Updated

a year ago
Attachment #8814904 - Flags: review?(wlachance)
(Assignee)

Updated

a year ago
Blocks: 1318021
No longer depends on: 1318021
Attachment #8814904 - Flags: review?(wlachance) → review+
(Assignee)

Updated

a year ago
No longer depends on: 1320451

Comment 3

a year ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/0c02c3fb8c0e973542e34c0072a4e64f3ede18cb
Bug 1318011 - Vagrant: Move debug-toolbar out of settings_local.py

https://github.com/mozilla/treeherder/commit/608687da927c8a609e0e5e78a40e636eb0ea3258
Bug 1318011 - Vagrant: Move logging config out of settings_local.py

It will be combined with the main logging config in bug 1318021.
(Assignee)

Comment 4

a year ago
This commit ended up in bug 1318021 instead...

Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/5dfb9782a23e3538b9ea1f5214125b874dbef376
Bug 1318021 - Vagrant: Remove support for settings_local.py

Since it is footgun-prone, discourages upstreaming of useful development
tricks & is unnecessary in an environment variable centric world.

The one remaining `BZ_API_URL` setting isn't actively used, and if this
changes in the future, it should be set via an environment variable
instead.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.