Uploading to FTP sites adds an underscore to the file name

RESOLVED DUPLICATE of bug 1319088

Status

()

RESOLVED DUPLICATE of bug 1319088
2 years ago
2 years ago

People

(Reporter: bdutchak, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

We had a client upload to our ftp site via http.  


Actual results:

When they uploaded a file, it put an underscore at the beginning of the file.  Other browsers don't produce the same result to the same ftp server.


Expected results:

The file name shouldn't be renamed.

Updated

2 years ago
Component: Untriaged → Networking: FTP
Product: Firefox → Core
Can you set up an test page?
Flags: needinfo?(bdutchak)
(Reporter)

Comment 2

2 years ago
(In reply to Dragana Damjanovic [:dragana] from comment #1)
> Can you set up an test page?

You can use the following:
http://ftp.greatwest.ca/
Username: Firefox
Password: test50

After you login, upload a file.  You should then see the file renamed with an underscore at the beginning of the filename.
Flags: needinfo?(bdutchak)

Comment 3

2 years ago
(In reply to bdutchak from comment #2)
> (In reply to Dragana Damjanovic [:dragana] from comment #1)
> > Can you set up an test page?
> 
> You can use the following:
> http://ftp.greatwest.ca/
> Username: Firefox
> Password: test50
> 
> After you login, upload a file.  You should then see the file renamed with
> an underscore at the beginning of the filename.

Did you fix the regression on your FTP? I can't reproduce it anymore.
Flags: needinfo?(bdutchak)

Comment 4

2 years ago
I see there is a "delete" feature now on the FTP. So maybe you found a workaround.

Anyway, I think your issue is dupe of bug 1319088.
(Reporter)

Comment 5

2 years ago
I was able to reproduce this issue just now and no we never fixed the regression, we haven't changed anything on the server side.

If it's related to bug 1319088 then would hope someone could verify that the fix for that bug is used to test this bug.
Flags: needinfo?(bdutchak)

Comment 6

2 years ago
I found it. If the user uses the drag&drop feature in the file list or in the file upload dialog box, it works normally. If the user, uses the browsing button to call the open file dialog box, the bug appears.

Comment 7

2 years ago
Indeed, it's a dupe of bug 1319088.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=974cfc
29c1e30561d40882c051f07724eff99491&tochange=5785e6e80c6696b6e941edcbc06583864d95
ae95

You can check the Netmonitor (F12) during ulpoading and the parameters of the request of the file  http://ftp.greatwest.ca/DragSend.upload:

Content-Disposition: form-data; name="image.jpeg"; filename="/image.jpeg"
Content-Type: image/jpeg

There is a slash before the filename "/image.jpeg" and after that, the FTP replaces the slash by an underscore (probably because slash is a character not allowed in filename).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1319088
You need to log in before you can comment on or make changes to this bug.