Add support for ICE end of candidate

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
normal
Rank:
18
RESOLVED FIXED
3 years ago
7 hours ago

People

(Reporter: drno, Assigned: bwc)

Tracking

(Blocks 2 bugs, {dev-doc-complete})

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 wontfix, firefox68 fixed)

Details

()

Attachments

(5 attachments)

Reporter

Description

3 years ago
The current spec allows the end of candidates null candidate to passed into addIceCandidate().
We need to add support for the in nICEr and then expose it via the JS API.
Update: http://w3c.github.io/webrtc-pc/#dom-rtcpeerconnection-addicecandidate now says addIceCandidate needs to support empty string to mean end of candidate gathering.

We also need to update the onicecandidate side to follow the spec [1] which says to emit such a candidate ahead of the existing null canddidate, as mentioned here [2]:

  "Create an RTCIceCandidate instance newCandidate, with sdpMid and sdpMLineIndex set to the values associated with this RTCIceTransport , with ufrag set to the ufrag of the generation of candidates for which gathering finished, with candidate set to an empty string"

[1] http://w3c.github.io/webrtc-pc/#rtcicetransport
[2] https://github.com/w3c/webrtc-pc/issues/1213#issuecomment-301861839
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
Once this is fixed, addIceCandidate should no longer allow null as a candidate argument.
Duplicate of this bug: 1529630
Assignee

Updated

3 months ago
Rank: 21 → 18
Priority: P3 → P2
Assignee

Updated

3 months ago
Assignee: nobody → docfaraday
Assignee

Comment 5

3 months ago

There's a spec bug that needs to be worked out here:

https://github.com/w3c/webrtc-pc/issues/2125

Assignee

Comment 8

3 months ago

Made a PR here: https://github.com/w3c/webrtc-pc/pull/2127

Going to have to jump through some hoops before it can be merged.

Attachment #9050452 - Attachment description: Bug 1318167 - Part 2: Incorporate remote end-of-candidates into SDP. → Bug 1318167 - Part 4: Incorporate remote end-of-candidates into SDP.
Assignee

Updated

3 months ago
Blocks: 1535690

Comment 16

3 months ago
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e71abf7c1375
Part 0: Re-enable some test-cases. r=jib
https://hg.mozilla.org/integration/autoland/rev/de9898be5bbe
Part 1: Give RTCIceCandidateInit.candidate a default value. r=smaug,jib
https://hg.mozilla.org/integration/autoland/rev/6d0193a41ab4
Part 2: Several test fixes that webidl changes highlighted, plus suppressions for tests that were succeeding for the wrong reasons. r=jib
https://hg.mozilla.org/integration/autoland/rev/b425ca25edc5
Part 3: Add some testing for a=end-of-candidates in remote SDP. r=jib
https://hg.mozilla.org/integration/autoland/rev/151f1392f619
Part 4: Incorporate remote end-of-candidates into SDP. r=mjf
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/15999 for changes under testing/web-platform/tests
Upstream PR merged

Documentation has been updated:

Please look this stuff over and if you see any problems, feel free to edit the articles directly or ping me here or in email with recommended changes.

You need to log in before you can comment on or make changes to this bug.